Welcome to the Linux Foundation Forum!

Lab 11.2 item 11 not getting objects

Hello all,

Here is the response as I try to inject the ingress controller

~/ingress-nginx$ ingress-nginx$ kubectl get ds myingress-ingress-nginx-controller -o yaml | linkerd inject --ingress - | kubectl apply -f -
ingress-nginx$: command not found

‼ no supported objects found

Any hints on what may be the cause?


  • chrispokorni
    chrispokorni Posts: 2,163

    Hi @nicocerquera,

    It seems you copy/pasted both the prompt and command.


  • yes, you are right, thank you for getting that!

  • Now I am having some trouble with the visualization of the web page, what app or command can I use to see that visualization of linkerd?

  • chrispokorni
    chrispokorni Posts: 2,163

    Hi @nicocerquera,

    The sequence of commands is in the lab guide. Did you see any errors while running them? Did you configure the web deployment and web service as described by steps 2 and 3?

    With all preliminary steps completed, you can open the console in the browser with the public IP of the node (step 4) and the NodePort of the web service (which is set to 31500 in step 3).


  • I noticed that the system stays in this loop

    I tried to go back to 11.1 and make sure steps 2 and 3 where correct and then I noticed what appears to be a racing state ^

  • looks like it is working but I can not access the dashboard externally:

    ncerquera@dev-node128:~$ curl http://localhost:50750
    <!doctype html>
    <html lang="en">
        <meta charset="utf-8">
        <meta name="viewport" content="width=device-width">
        <meta name="description" content="Linkerd">
        <meta name="keywords" content="Linkerd">
        <link rel="icon" type="image/png" href="/dist/img/favicon.png">
        <link href="https://fonts.googleapis.com/css?family=Lato:300,400,700,900" rel="stylesheet">
        <script id="bundle" type="text/javascript" src="/dist/index_bundle.js" async></script>
      <div class="main" id="main"
  • chrispokorni
    chrispokorni Posts: 2,163
    edited April 2023

    Hi @nicocerquera,

    Have you tried following the instructions from the lab guide? Step 5 mentions the following:

    From you local system open a browser and go to the public IP and the high-number nodePort

    What was the outcome?



Upcoming Training