Welcome to the Linux Foundation Forum!

Clarification regarding Lab 3.2

Options

Hello,

I have been unable to complete "Lab 3.2" as prescribed.

Note: Virtual machine running Ubuntu 20.04 was used to attempt the lab.

I edited and used the interfaces file provided with the course resources. Next, I ran "sudo systemctl restart NetworkManager." As expected, the Network Manager sets the interface device to an "unmanaged" state. However, it does not initialize the interface adapter with the static IP address set in the interface's configuration file. Please refer to screenshot#1 below. Moreover, the interface is not even functional after rebooting the system. Please refer to screenshot#2 below.

Screenshot#1

Screenshot#2

In contrast to the prescribed instructions, I tried the lab with "netplan" and was able to configure the interface that persisted system reboots. Please refer to screenshot#3 below.

Screenshot#3

Please provide further clarification on the lab and best practices to use to configure network adaptors in Ubuntu.

Thank you,
Amar

Categories

Upcoming Training