Welcome to the Linux Foundation Forum!

E: ... xUbuntu_20.04 Release' does not have a Release file.

Options

After running the following command lines:

echo "deb https://download.opensuse.org/repositories/devel:/kubic:/libcontainers:/stable /xUbuntu_${VERSION_ID}/ /" | sudo tee /etc/apt/sources.list.d/devel:kubic:libcontainers:stable.list

curl -L "https://download.opensuse.org/repositories/devel:/kubic:/libcontainers:/stable/xUbuntu_${VERSION_ID}/Release.key" | sudo apt-key add -

sudo apt update

getting the following error:

Hit:1 http://us-central1.gce.archive.ubuntu.com/ubuntu focal InRelease
Hit:2 http://us-central1.gce.archive.ubuntu.com/ubuntu focal-updates InRelease                                                          
Hit:3 http://us-central1.gce.archive.ubuntu.com/ubuntu focal-backports InRelease                                                        
Hit:4 https://download.docker.com/linux/ubuntu focal InRelease                                                                          
Hit:5 http://security.ubuntu.com/ubuntu focal-security InRelease                                                                        
Ign:6 https://download.opensuse.org/repositories/devel-kubic-libcontainers-stable/xUbuntu_20.04  InRelease     
Err:7 https://download.opensuse.org/repositories/devel-kubic-libcontainers-stable/xUbuntu_20.04  Release
  404  Not Found [IP: 195.135.221.134 443]
Reading package lists... Done
E: The repository 'https://download.opensuse.org/repositories/devel-kubic-libcontainers-stable/xUbuntu_20.04  Release' does not have a Release file.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.

Comments

  • chrispokorni
    chrispokorni Posts: 2,190
    Options

    Hi @alireza1222,

    Please try these updated installation steps, from the official podman docs:

    sudo mkdir -p /etc/apt/keyrings

    curl -fsSL \
      https://download.opensuse.org/repositories/devel:kubic:libcontainers:unstable/xUbuntu_$(lsb_release -rs)/Release.key \
      | gpg --dearmor \
      | sudo tee /etc/apt/keyrings/devel_kubic_libcontainers_unstable.gpg > /dev/null
    
    echo \
      "deb [arch=$(dpkg --print-architecture) signed-by=/etc/apt/keyrings/devel_kubic_libcontainers_unstable.gpg]\
        https://download.opensuse.org/repositories/devel:kubic:libcontainers:unstable/xUbuntu_$(lsb_release -rs)/ /" \
      | sudo tee /etc/apt/sources.list.d/devel:kubic:libcontainers:unstable.list > /dev/null
    

    sudo apt-get update -qq

    sudo apt-get -qq -y install podman

    Regards,
    -Chris

  • dickvanhaastrecht
    edited April 2023
    Options

    Good morning,

    I have tried the updated installation steps but am still stuck with the following message.

    E: The repository 'http://download.opensuse.org/repositories/devel:/kubic:/libcontainers:/stable/xUbuntu_ Release' does not have a Release file. E: The repository 'https://download.opensuse.org/repositories/devel:kubic:libcontainers:unstable/xUbuntu_20.04 Release' does not have a Release file.

    It seems there is no repository for the podman on ubuntu 20.04. Is it better to proceed on ubuntu 22.04 as this has podman in the repository's?

    (red) I did found another tutorial on how to install podman on Ubuntu 20.04 here:

    https://computingforgeeks.com/how-to-install-podman-on-ubuntu/

    This did do the trick and installed podman. Still not quite sure on how to proceed on this as the messages around podman support on Ubuntu are not the best with support on the latest release.

  • chrispokorni
    chrispokorni Posts: 2,190
    Options

    Hi @dickvanhaastrecht,

    You are correct, Ubuntu 20.04 LTS does not have a podman repository. The installation relies on the kubic repository instead.

    If the commands from the lab guide are not successfully completed, then the installation will fail.
    Please ensure the copy/paste generates the commands as they are presented in the lab guide.

    Just now, I was able to install podman 3.4.2 on Ubuntu 20.04 LTS, by following the lab guide alone.

    Regards,
    -Chris

Categories

Upcoming Training