Welcome to the Linux Foundation Forum!

Deployment failure

Options

I am trying to do the simpleapp deployment from exercise 3.2 and I am having an error.
I am doing the deployment on my master node and I have tried many things but nothing seems to work.

It seems there is something wrong with the tcp lookup of the local container registry.

thats my config.toml

what am I missing? The nodes and containerd reboot also happened without any issues.

Best Answer

  • chrispokorni
    chrispokorni Posts: 2,220
    Answer ✓
    Options

    Hi @madhu91s,

    On the worker you still have a typo to be fixed, on the same "endpoint" line, the port number should be ":5000". Your file has the port number incorrectly displayed as ".5000"

    Please pay close attention and double check all your work before posting.

    Regards,
    -Chris

Answers

  • madhu91s
    Options

    FYI, the image is available though

  • fazlur.khan
    Options

    @madhu91s

    I find this in the lab guide. Please make changes accordingly and verify once.

    [plugins."io.containerd.grpc.v1.cri".registry.mirrors]
    [plugins."io.containerd.grpc.v1.cri".registry.mirrors."*"] #<-- Add these two lines
    endpoint = ["http://10.97.40.62:5000"] #<-- Remember YOUR IP here

    Also, ensure the service ip is same and also the pods are running. If possible, please paste the output of below command.

    kubectl get all

  • madhu91s
    Options

    @fazlur.khan said:
    @madhu91s

    I find this in the lab guide. Please make changes accordingly and verify once.

    [plugins."io.containerd.grpc.v1.cri".registry.mirrors]
    [plugins."io.containerd.grpc.v1.cri".registry.mirrors."*"] #<-- Add these two lines
    endpoint = ["http://10.97.40.62:5000"] #<-- Remember YOUR IP here

    Also, ensure the service ip is same and also the pods are running. If possible, please paste the output of below command.

    kubectl get all

    @falzur.khan thank you for your response, the lab guide instruction did not help me, so I made the changes as per here - https://forum.linuxfoundation.org/discussion/862401/lfd259-course-updated-to-v1-25-1-11-8-2022#latest

    but that did not help either.

    my output of kubectl get all looks like this -

  • chrispokorni
    Options

    Hi @madhu91s,

    I would take another look at the config.toml file and fix the indentation. What I can tell is that the "endpoint" line needs to be fixed, then restart the containerd service.

    Regards,
    -Chris

  • madhu91s
    Options

    @chrispokorni said:
    Hi @madhu91s,

    I would take another look at the config.toml file and fix the indentation. What I can tell is that the "endpoint" line needs to be fixed, then restart the containerd service.

    Regards,
    -Chris

    Hi, I changed the indentation and validated it through a validator. It seems fine though but the problem still persists. I restarted containerd too.


  • madhu91s
    Options

    @chrispokorni said:
    Hi @madhu91s,

    On the worker you still have a typo to be fixed, on the same "endpoint" line, the port number should be ":5000". Your file has the port number incorrectly displayed as ".5000"

    Please pay close attention and double check all your work before posting.

    Regards,
    -Chris

    Thank you @chrispokorni, that indeed was the problem!

Categories

Upcoming Training