Welcome to the Linux Foundation Forum!

Lab 10: Running Containers at Scale with k8S - GC hosted Vote application is crashing on selection

paccha5065
paccha5065 Posts: 11
edited January 12 in LFS261 Class Forum

Hi,

As mentioned in the exercise, I have hosted the vote application and redis backend in Google Cloud platform.

Created required services and exposed the ports.
But even then on the selection of vote, the app crashes with an internal error:

Please let me know, if i am missing anything here.

PS: Also, please note that while trying to expose a redis port i.e

kubectl expose deployment redis --port=6739 –name=redis

i got a following error:
(ci-cd-370806)$ kubectl expose deployment redis --port=6739 –name=redis
service/redis exposed
Error from server (NotFound): deployments.apps "–name=redis" not found

but after this i tried to remove the name in the command as follows:
**kubectl expose deployment redis --port=6739 **
which went fine and exposed a service.

However in both the cases app was crashing.

Pease let me know, if you need any further details.

Comments

  • jleveque
    jleveque Posts: 3

    Hi there,

    I'm chiming in to say I'm seeing the same issue in Lab 10. I've tried troubleshooting it myself and I am at a loss for the fix.

    The only new information I can provide is that the apparent typo in the kubectl command (using only one '-' in the -name option) isn't the root of the issue. I get the same result with --name=redis:

    $ kubectl expose deployment redis --port=6739 –-name=redis
    service/redis exposed
    Error from server (NotFound): deployments.apps "–-name=redis" not found
    

    I'm going to move forward to the next chapter and hope that this doesn't cause issues in a future lab, but I'd appreciate some insight on the issue.

  • jleveque
    jleveque Posts: 3
    edited January 23

    Found the issue: The expose command should use port "6379", not "6739" as stated in the lab.

    I found the following error in the logs of my vote-xxxxx service:

    ConnectionError: Error connecting to redis:6379. timed out.
    

    ...and noticed the difference between the port expected by the app and what I'd used in my expose command. Sure enough, the vote app works perfectly once the redis service is set to use port 6379.

    Please update the lab materials to use the following command:

    $ kubectl expose deployment redis --port=6379 –-name=redis
    

    As a sidenote: The 'deployments.apps "–-name=redis" not found' error I was seeing earlier no longer seems to be an issue. Not sure what fixed it (maybe my brand-new cluster needed a few more hours to fully initalize?) but the "--name=redis" option works as expected, and the "-name" version (with one dash) now gives a proper error message:

    Error from server (NotFound): namespaces "ame=redis" not found
    
  • luisviveropena
    luisviveropena Posts: 1,101
    edited January 25

    Hi @jleveque,

    If an application is crashing, I would try the following:

    1.- Look at the log files and see if there is anything I can have useful information. Look for existing bugs for the error.

    2.- If you don't find any existing bug or any clear indication of what's failing, I'd try creating a new set of cloud systems to try on. Perhaps something became corrupted.

    3.- Check on any running firewall, Selinux, Apparmor.

    4.- Check on the ports you are working with. Ask yourself if the ports are being used by any other application.

    I'll try to replicate the issue; what OS flavor and version are you using in the systems? What's the version of kubectl?

    Regards,
    Luis.

  • fcioanca
    fcioanca Posts: 1,761

    The expose command in Lab 10 was updated to use port "6379", instead of "6739".

Categories

Upcoming Training