Welcome to the Linux Foundation Forum!

Lab 9: Quality Gate got Stuck

To make the conversation a little faster I am adding an earlier issue link that I am facing currently.
https://forum.linuxfoundation.org/discussion/862731/lab-9-quality-gate-error

As I commented in the earlier ticket, my quality gate process is now stuck as follows:
Checking status of SonarQube task 'AYWhzCbQwpOPUdInVL2u' on server 'sonar-instavote'
SonarQube task 'AYWhzCbQwpOPUdInVL2u' status is 'IN_PROGRESS'

Can some one please look into the issue and resolve it.

Comments

  • Hi @paccha5065, can you check/provide the Sonarqube log files, please? Perhaps something can be found in there.

    Regards,
    Luis.

  • Hi Luis,

    May i know, from where can I get this Sonarqube log files.

    As we did only the Integration of it in Jenkins, I am not finding any log files related to it in jenkins.

    Regards,
    prashanth

  • any updates here..

  • Hi @paccha5065, please take a look to the official Sonarqube documentation about this:

    https://docs.sonarqube.org/9.6/setup-and-upgrade/troubleshooting/

    Regards,
    Luis.

  • ninmar
    ninmar Posts: 1

    I had this problem. I had to go into the SonarCloud project and select Administration > Quality Gate. When I saw QG02 was selected there was a message I had to confirm. Don't remember exactly what it said but a manual run on Jenkins allowed the pipeline to succeed.

  • luisviveropena
    luisviveropena Posts: 994
    edited January 31

    Hi @ninmar, it would be awesome if you could provide details about the solution you found.

    Regards,
    Luis.

Categories

Upcoming Training