Welcome to the Linux Foundation Forum!

Excercise 1.1 Configuring the System for sudo

I just start the LFS207. I installed the latest Linux Mint on my desktop and dual bootup with my Windows 10. When I tried to su root, it is asking for the PW. I have tried to enter "mint' as I searched on Google. I also tried difference PW and it does not let me login to root. I am new with Linux. Can someone help me? Thanks


  • coop
    coop Posts: 913

    i believe Mint is based on Ubuntu, in which normal users never ever use "su" and only use "sudo", which many other distros, including Fedora, openSUSE, etc now do as well, at least by default. So if you need privileged commands just do "sudo command ..." and use your normal password. If you want to run a bunch of commands without typing sudo all the time you can cheat by doing "sudo su" and that should give you essentially a root prompt. I'm sorry but I do not have a Mint system to test on. I stopped playing with Mint years ago as personally I just find it not as well maintained as the distributions it stems from and I saw no advantage to it, but I'm an experienced user of course :)

    You can indeed set up a root password and use su on Ubuntu/Mint, but it is not a good idea and is deprecated and I won't try to explain how :)

  • Hi @namchuongdai,

    1.- Have you tried using sudo?

    2.- You also can use one of our pre-built VMs. You can find the details here:



  • Thank you, Coop
    sudo root
    [sudo] passwor for xxxx: (I entered my PW)
    sudo: root: command not found.

    Thank you, Luisviveropena
    I will try to use pre-built VMs.

  • coop
    coop Posts: 913

    this command makes no sense ("sudo root") you can do "sudo su" (no other arguments)

  • Hi @namchuongdai, yeah, the pre-built VMs will work.



Upcoming Training