Welcome to the Linux Foundation Forum!

Not able to install Chaincode

Dear All,

I am new to Hyperledger Fabric and am trying to implement a sample project - Fabcar - in my Amazon VM (Ubuntu 20.4). When I am trying to execute the chain-code, I am getting the following error:-

Error: chaincode install failed with status: 500 - failed to invoke backing implementation of 'InstallChaincode': could not build chaincode: docker build failed: docker image build failed: docker build failed: Error returned from build: 1 "go: inconsistent vendoring in /chaincode/input/src:

Can someone please suggest how to fix it?

Thanks a lot in advance!

Answers

  • Bobbijn
    Bobbijn Posts: 154

    @gauavgoenka17, Let's see if we can get to the bottom of this. This error message usually occurs because your Docker build may not have loaded correctly or you have a different version. Try taking down the blockchain and restarting it. What exercise in the Lab is this happening? Bobbi

Categories

Upcoming Training