Welcome to the Linux Foundation Forum!

Still unable to join worker node to master node, please help

when I run the kubeadm join command on my worker node, I get this output:

[preflight] Running pre-flight checks
[WARNING SystemVerification]: missing optional cgroups: blkio


  • lf1d
    lf1d Posts: 13

    Are you using Ubuntu 20.04, or a newer version?

  • @if1d yes, using Ubuntu 22.04

  • lf1d
    lf1d Posts: 13

    @tstaffordsmith, the labs support Ubuntu version 20.04. You are using version 22.04.

    The solution is to use Ubuntu 20.04.

  • I had the same issue, but on Ubuntu 20.04, which was suggested in labs. I exposed port:6443 in Security Group of my AWS EC2 instance and worked.

  • Try not enabling firewall during the EC2 setup and you should be good to go

  • Hi @jakub.przybyla,

    I would recommend watching the demo video from the introductory chapter that presents critical configuration options for setting up the VPC, SG, and the EC2 instances on AWS.


  • Hi @chrispokorni ,
    I went through the initial SG configuration proposed in video and the way was to open all traffic to all ports, not just 6443, apparently I have missed it. Thanks for the hint!


Upcoming Training