Welcome to the Linux Foundation Forum!

How to fix Error when attempting to peer channel list

financexord123
financexord123 Posts: 2
edited November 17 in LFD272 Class Forum

I have been trying to get the peer channel list command to work but I am getting the following error.

Error: error getting endorser client for channel: endorser client failed to connect to peer0.org1.example.com:7051: failed to create new connection: connection error: desc = "transport: error while dialing: dial tcp: lookup peer0.org1.example.com: no such host":

What I'm doing is creating a channel using
sudo ./network.sh up createChannel -ca -s CouchDB

After that I override all the necessary Environment variables mentioned in the core.yaml file present in the config folder and then attempting to run

sudo -E peer channel list

After which I'm getting the error mentioned above. I Am stuck for some time so please help.

Answers

  • Bobbijn
    Bobbijn Posts: 148

    @financexord123, Hello, let's see if we can figure out the issue. Are you experiencing this issue during the Lab exercise_ Run the Hyperledger Fabric network,_ test-network, Spin up the network_ in Lab 2.1 on page 24?. Have you tried shutting down and restarting the network? Bobbi

  • Hey Bibbijn, Yeah I did try uping and downing the network again but the problem persisted, I fixed the problem though I had to change the hostname from peer0.org1.example.com:7051 to localhost:7051. The question is that if it is done in the tutorial like this why isn't it working?

  • Bobbijn
    Bobbijn Posts: 148

    @[email protected] I am glad you worked through the issue! Bobbi

Categories

Upcoming Training