Welcome to the Linux Foundation Forum!

13.3 ensure CRDs are installed first

Attempting to install metrics server, I am getting the following message:
error: resource mapping not found for name: "v1beta1.metrics.k8s.io" namespace: "" from "https://github.com/kubernetes-sigs/metrics-server/releases/download/v0.3.7/components.yaml": no matches for kind "APIService" in version "apiregistration.k8s.io/v1beta1"
ensure CRDs are installed first

The following line is missing from output:
apiservice.apiregistration.k8s.io/v1beta1.metrics.k8s.io created

The apiregistration.k8s.io/v1beta1 API version of APIService is no longer served as of v1.22.


  • skopos
    skopos Posts: 21

    I think the command has changed, unfortunately, I lost track of that fixed command.
    Maybe @chrispokorni can help us.

  • skopos
    skopos Posts: 21

  • I've installed 0.4.1 (there are a lot of even newer versions, up to 0.6.x) and it worked flawlessly.

    If you've already tried 0.3.7, run the same command with delete -f... instead of trying the newer version first.

  • Hi @skopos,

    The metrics-server installation steps can be found here.



Upcoming Training