Welcome to the Linux Foundation Forum!

problem in lab 22.1

Hi,

I am reviewing all of the exercises for both LFS201 and LFS211 in order to study for the LFCS exam. When I did this exercise in my computer (fedora workstation 36) I didnt have any problem, I freed some empty space directly on my SDD, then I created a new partition and everything worked just fine.

Now, I'm trying to do the same using a cent-OS container using Google Cloud Services, and I cannot get past this command:

sudo cryptsetup luksFormat /dev/loop0p1

I am using a loopback device, as you can see, since I could not make a different partition directly from the disk. I already found a link to do this , but anyhow, I really want to find out why I cannot do it.

When I try to input that command, the terminal always responds this:
sudo cryptsetup luksFormat /dev/loop3
WARNING: Device /dev/loop3 already contains a 'dos' partition signature.

WARNING!
========
This will overwrite data on /dev/loop3 irrevocably.

Are you sure? (Type 'yes' in capital letters): YES
Enter passphrase for /dev/loop0p3:
Verify passphrase:
Device /dev/loop3 is in use. Can not proceed with format operation.

I tried to do it with four different loopback devices. My machine looks like this:
df -Th
Filesystem Type Size Used Avail Use% Mounted on
devtmpfs devtmpfs 3.8G 0 3.8G 0% /dev
tmpfs tmpfs 3.8G 0 3.8G 0% /dev/shm
tmpfs tmpfs 3.8G 8.4M 3.8G 1% /run
tmpfs tmpfs 3.8G 0 3.8G 0% /sys/fs/cgroup
/dev/sda2 xfs 20G 4.4G 16G 23% /
/dev/sda1 vfat 200M 7.3M 193M 4% /boot/efi
/dev/loop1 ext4 976M 2.6M 907M 1% /home/student2/mountpoint
/dev/loop0p1 ext3 233M 2.1M 219M 1% /home/student2/mntpoint1
/dev/loop2 ext4 233M 2.1M 215M 1% /home/student2/mntpoint2
/dev/loop3 vfat 240M 0 240M 0% /home/student2/mntpoint3
tmpfs tmpfs 777M 0 777M 0% /run/user/1000

lsblk
NAME MAJ:MIN RM SIZE RO TYPE MOUNTPOINT
loop0 7:0 0 763M 0 loop
├─loop0p1 259:0 0 244.1M 0 loop /home/student2/mntpoint1
├─loop0p2 259:1 0 244.1M 0 loop
└─loop0p3 259:2 0 239.4M 0 loop
loop1 7:1 0 1G 0 loop /home/student2/mountpoint
loop2 7:2 0 244.1M 0 loop /home/student2/mntpoint2
loop3 7:3 0 239.4M 0 loop /home/student2/mntpoint3
sda 8:0 0 20G 0 disk
├─sda1 8:1 0 200M 0 part /boot/efi
└─sda2 8:2 0 19.8G 0 part /

Comments

  • coop
    coop Posts: 879

    you are lucky that your system is preventing from probably committing suicide :) /dev/loop3 is already mounted on /home/student2/mntpoint3. You need to unmount it first, or you need to choose an unused loop device, say loop4 (see losetup). We generally don't support doing the course on
    containers, although there is no reason that I know of this should not work, but I also don't know what options the kernel was compiled with. But since you already have loopback devices you are probably ok. Anyway, the error message is rather specific so pay attention to it :)

  • :D thanks!!! I thought that the test was on a containers environment!! thanks for the guidance!

  • coop
    coop Posts: 879

    While we do not answer exam related questions here (training and certification staffs are separate) I can assure you that you will be ssh-ing into a virtual machine, and you have a choice between c9stream and ubuntu 20.04. This may indeed be a container for all I know but no one has ever asked me about this. It is all command line stuff. I have no idea how much they ask about partitioning etc....you have to consult the guides but they probably don't really tell you :)

Categories

Upcoming Training