Welcome to the Linux Foundation Forum!

LFS 201 Lab 5.1 Version Control with git (Ubuntu 22.04) error with installing git

Best Answer

  • coop
    coop Posts: 880
    Answer ✓

    This is a bug in the distribution I have seen before. It should not try to install the "sysvinit" and "systemd" git packages at the same time. It is a pretty new bug so the course does not reflect this. Probably all you need to say is "sudo apt install git" (not git*) anyway, so try that. I'm not sure all that will bring in; to do labs you may later need to git something like install git-svn or gitweb or cvs but that would be obvious. This is Linux and I'm sure this bug will get fixed but I cannot tell you when. It is rare that debian-based systems are this dumb :)

Answers

  • Hi @mminden,

    Did you try 'sudo apt-get update' first? What OS version are you working with? Is it a VM provided by us, right?

    Regards,
    Luis.

  • mminden
    mminden Posts: 2

    @luisviveropena
    Yes, I did run the 'sudo apt-get update' prior and the version is 22.04.01 (desktop). This is a brand new VM I built in VirtualBox for the course.

    @coop
    The suggestion to use git and not git* worked and able to proceed with the lab.

  • Hi @mminden , I'm glad that fixed it!

    Regards,
    Luis.

Categories

Upcoming Training