Welcome to the Linux Foundation Forum!

lab 2.1 echo: write error: No such process

Options

Hi there,

When trying to do the lab 2.1, I'm stuck at the part when we are supposed to enter:

student@ubuntu:/sys/fs/cgroup/freezer/mycgroup$ sudo bash -c 'echo 20913 >>tasks'

I get the following error:

echo: write error: No such process

I have tried several times, by opening and closing a new terminal window or a new terminal tab, then entering the corresponding PID number, and I always get the same error. I had no problem following along up until here.

Comments

  • chrispokorni
    chrispokorni Posts: 2,193
    Options

    Hi @donquijotedelasnubes,

    Please provide the following commands and their respective outputs:

    First terminal student@ubuntu:/sys/fs/cgroup/freezer/mycgroup$ cat tasks

    Second terminal student@ubuntu:~$ ps

    First terminal student@ubuntu:/sys/fs/cgroup/freezer/mycgroup$ sudo bash -c 'echo PID >> tasks' by replacing the PID with the value you are using to write into the tasks file.

    Regards,
    -Chris

  • donquijotedelasnubes
    Options

    Hi @chrispokorni

    student@ubuntu:/sys/fs/cgroup/freezer/mycgroup$ cat task

    student@ubuntu:~$ ps
    PID TTY TIME CMD
    13860 pts/1 00:00:00 bash
    13872 pts/1 00:00:00 ps

    student@ubuntu:/sys/fs/cgroup/freezer/mycgroup$ sudo bash -c 'echo PID >> tasks

    Now it worked ... I dont know why. Sorry for the inconvenience

  • dalbaran
    Options

    I had the same issue, I realized the tasks file does not exist, and I´m not able to create it.

  • chrispokorni
    chrispokorni Posts: 2,193
    Options

    Hi @dalbaran,

    Can you provide a screenshot of the commands you run to populate and/or create the tasks file and their respective outputs showing errors?

    Regards,
    -Chris

Categories

Upcoming Training