Welcome to the Linux Foundation Forum!

issue with podman insecure setting

I am going through Lab 3.2 for LFD259 and I am trying to get an image from the repository I created. I can do it when on the CP server, but cannot from the worked server. The error message is that the podman request is getting an http answer to an https request, despite the fact that the registry on the worker is configured with insecure=true. Is there a setting I missed somewhere?

Comments

  • mdangear
    mdangear Posts: 3

    Even in the CP node I cannot pull images, getting an error. Could this be an issue with the Google Cloud VMs? some networking setup missing there? I followed the steps in the tutorial and did not see anything special related to this.

  • chrispokorni
    chrispokorni Posts: 1,493

    Hi @mdangear,

    In this exercise, such a behavior may be related to misconfigured registries.conf files on the cp and worker nodes. I'd recommend revisiting steps 4 and 11, to ensure the following:

    [[registry]] # is uncommented

    insecure = true # is uncommented, set to "true", with 1 space before and after the "=" sign

    location = "10.97.40.62:5000" # is uncommented and shows the ClusterIP address of your registry service (as extracted by the command found in step 2), also with 1 space before and after the "=" sign

    Once you make the necessary corrections (if any are needed) please restart both crio services on the cp and worker nodes, update the repo variables if needed on both nodes, then try the push and pull commands again. If they throw some initial errors, try them several times, as they may reference some cached IP addresses or config values.

    If this does not resolve the issue, we may need to take a closer look at your infrastructure configuration on GCP.

    Regards,
    -Chris

Categories

Upcoming Training