Welcome to the Linux Foundation Forum!

Lab 3.6

After executing the containerd-setup script on Ubuntu 20.04, the nodes fails to get into ready status. The kubelet service fails with the following error:
"Failed to run kubelet" err="failed to run Kubelet: failed to create kubelet: get remote runtime typed version failed: rpc error: code = Unimplemented desc = unknown service runtime.v1alpha2.RuntimeService"

Answers

  • chrispokorni
    chrispokorni Posts: 1,614

    Hi @borislav.velkov,

    The containerd-setup.txt creates the /etc/containerd/config.toml file twice - first time around line 67, and second time around line 145. With the config.toml file in its first format (as presented around line 67), Lab exercise 3.6 works successfully - the node becomes ready, and the simple-gvisor pod gets scheduled and achieves a running state.

    Regards,
    -Chris

  • Hi, thanks for your reply. I think I tried that and the node went in ready status but the gvisor pod was not starting but I will try again. If this is the case maybe the lab should be updated to reflect that.

  • Hello, I had the same error.
    Using the first config for config.toml file node is in "Ready" status and pod gets scheduled successful.
    I think the lab should be updated.
    Thanks for the solution @chrispokorni

  • hectorvido
    hectorvido Posts: 1
    edited October 4

    I had the same problem here in Ubuntu 20.04, the lab only works with the first /etc/containerd/config.toml.
    I agree with mboleso, the lab should be updated.

Categories

Upcoming Training