Welcome to the Linux Foundation Forum!

[linkerd] where to pass the flag `--set proxyInit.runAsRoot=true`?

Hello,
The pre-checks say: "There are nodes using the docker container runtime and proxy-init container must run as root user. Try installing linkerd via --set proxyInit.runAsRoot=true"
But when I run the install script with:

curl -sL run.linkerd.io/install > linkerd-install.sh
sudo ./linkerd-install.sh --set proxyInit.runAsRoot=true

the same happens.
Maybe it takes to install Linkerd on the cloud? My cluster runs in virt-manager with 2 nodes

Best Answers

Answers

  • Same on aws:

    [email protected]:~$ curl -sL run.linkerd.io/install | sh
    Downloading linkerd2-cli-stable-2.11.2-linux-amd64...
      % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                     Dload  Upload   Total   Spent    Left  Speed
      0     0    0     0    0     0      0      0 --:--:-- --:--:-- --:--:--     0
    100 44.7M  100 44.7M    0     0  6348k      0  0:00:07  0:00:07 --:--:-- 7091k
    Download complete!
    
    Validating checksum...
    Checksum valid.
    
    Linkerd stable-2.11.2 was successfully installed 🎉
    
    
    Add the linkerd CLI to your path with:
    
      export PATH=$PATH:/home/ubuntu/.linkerd2/bin
    
    Now run:
    
      linkerd check --pre                     # validate that Linkerd can be installed
      linkerd install | kubectl apply -f -    # install the control plane into the 'linkerd' namespace
      linkerd check                           # validate everything worked!
      linkerd dashboard                       # launch the dashboard
    
    Looking for more? Visit https://linkerd.io/2/tasks
    
    [email protected]:~$ export PATH=$PATH:/home/ubuntu/.linkerd2/bin
    [email protected]:~$ linkerd check --pre
    there are nodes using the docker container runtime and proxy-init container must run as root user.
    try installing linkerd via --set proxyInit.runAsRoot=true
    

    But a simple service exposed doesn't seem to work neither...

  • Now I get:

    ‼ cluster networks can be verified
        the following nodes do not expose a podCIDR:
        wnode
        see https://linkerd.io/2.11/checks/#l5d-cluster-networks-verified for hints
    

    but since only calico sets the pod Cidr, the worker node can't expose one?

  • Hi @chrispokorni
    Of course, calico have more options than just setting a Cidr. Thank you for the link

  • Hi @alihasanahmedk
    Great, thank you for your help

  • Always welcome @thomas.bucaioni

Categories

Upcoming Training