Welcome to the Linux Foundation Forum!

Lab 2.2. Deploy a New Cluster perfectly followed instructions fail


I am fairly sure I perfectly followed 01. INTRODUCTION - IMPORTANT: Using GCE to Set Up the Lab Environment as well as Lab 2.1 and Lab 2.2 up to the command "bash k8scp.sh | tee $HOME/cp.out"

I even deleted and created cp again to make sure.

Unfortunately I am not good enough at general linux administration to troubleshoot the particular error without help.

Can somebody help with ideas?

Here is the last part of the output:

W0519 16:40:43.272279 16088 utils.go:69] The recommended value for "resolvConf" in "KubeletConfiguration" is: /run/systemd/resolve/resolv.conf; the provided value is: /run/systemd/resolve/resolv.conf
[init] Using Kubernetes version: v1.23.1
[preflight] Running pre-flight checks
error execution phase preflight: [preflight] Some fatal errors occurred:
[ERROR CRI]: container runtime is not running: output: time="2022-05-19T16:40:45Z" level=fatal msg="connect: connect endpoint 'unix:///var/run/crio/crio.sock', make sure you are running as root and the endpoint has been started: context deadline exceeded"
, error: exit status 1
[preflight] If you know what you are doing, you can make a check non-fatal with --ignore-preflight-errors=...
To see the stack trace of this error execute with --v=5 or higher
Running the steps explained at the end of the init output for you
cp: cannot stat '/etc/kubernetes/admin.conf': No such file or directory
chown: cannot access '/home/student/.kube/config': No such file or directory
Apply Calico network plugin from ProjectCalico.org
If you see an error they may have updated the yaml file
Use a browser, navigate to the site and find the updated file
The connection to the server localhost:8080 was refused - did you specify the right host or port?

alias sudo=sudo
alias docker=podman
--2022-05-19 16:40:54-- https://get.helm.sh/helm-v3.7.0-linux-amd64.tar.gz
Resolving get.helm.sh (get.helm.sh)..., 2606:2800:11f:1cb7:261b:1f9c:2074:3c
Connecting to get.helm.sh (get.helm.sh)||:443... connected.
HTTP request sent, awaiting response... 200 OK
Length: 13861119 (13M) [application/x-tar]
Saving to: ‘helm-v3.7.0-linux-amd64.tar.gz’

helm-v3.7.0-linux-amd64.tar.gz 100%[====================================================================================================================================================================================================>] 13.22M --.-KB/s in 0.1s

2022-05-19 16:40:54 (119 MB/s) - ‘helm-v3.7.0-linux-amd64.tar.gz’ saved [13861119/13861119]

You should see this node in the output below
It can take up to a mintue for node to show Ready status

The connection to the server localhost:8080 was refused - did you specify the right host or port?

Script finished. Move to the next step


  • chrispokorni
    chrispokorni Posts: 2,164

    Hi @arqa,

    You can re-run the script but remove podman and buildah from the installation command, and then install podman manually.

    To install podman, as a non-root user execute the following sequence:

    sudo apt-mark hold kubeadm kubelet kubectl

    . /etc/os-release

    echo "deb http://download.opensuse.org/repositories/devel:/kubic:/libcontainers:/stable/xUbuntu_${VERSION_ID}/ /" | sudo tee /etc/apt/sources.list.d/devel:kubic:libcontainers:stable.list

    curl -L "https://download.opensuse.org/repositories/devel:/kubic:/libcontainers:/stable/xUbuntu_${VERSION_ID}/Release.key" | sudo apt-key add -

    sudo apt update

    sudo apt upgrade -y

    sudo apt install -y gnupg2

    sudo apt install -y podman

    sudo apt install -y podman --fix-missing

    If the installation errors persist, re-run the following sequence:

    sudo apt install -y gnupg2

    sudo apt install -y podman

    sudo apt install -y podman --fix-missing

    sudo apt install -y gnupg2

    sudo apt install -y podman --fix-missing


  • arqa
    arqa Posts: 2

    Hello Chris,

    thank you for your support. Unfortunately, on the existing node this did not help. Fortunately, when I tried creating a new node and following the instructions closely a third time - this time it worked fine.



Upcoming Training