Welcome to the Linux Foundation Forum!

ready-for.sh doesn't work on RHEL 8.5 as PowerTools doesn't exist

ashraf.fouad
ashraf.fouad Posts: 24
edited April 21 in LFD201 Class Forum

Hello,
I'm trying to setup my RHEL 8.5 VM machine.

NAME="Red Hat Enterprise Linux VERSION="8.5 (Ootpa)

When I run
./ready-for.sh --fix-missing --install LFD201

I'm getting error
No matching repo to modify: powertools.

I have checked several posts related to this issue, till I find post in Red Hat forum stating that "PowerTools is a CentOS repository. On RHEL 8 we have the CodeReady Builder repository".

This was the first error, the second error as well is

Some packages didn't install: collectl

I'm not sure if it is related to the powertools or it is another error.

Appreciate your suggestion to resolve.

Best Answer

  • coop
    coop Posts: 844
    Answer ✓

    It's a warning you can ignore. It was something from RHEL 7 that should have been fixed. Yes you should use the CodeReady Builder repo. I'll tell the ready-for.sh maintainer this has not been fixed. "collectl" is in the EPEL repo which you should make sure to install as a bunch of stuff is in there. The ready-for.sh script should have installed that I believe but you can always get it manually

Answers

  • Seems also I'm having trouble with "collectl" in RHEL 8.5

    when I run
    yum --disablerepo="*" --enablerepo="epel" list available | grep collectl
    It displays nothing

    I have checked this link and seems doesn't exist for version 8 while this link shows it exists in version 7

  • coop
    coop Posts: 844

    hmm. I just checked on my system which is a true RHEL 8 (not CentOS) and I found that I have installed the el7 package -- it seems to work just fine. I did not bother to check the version before, just that dnf info showed it as EPEL. I don't think you even need collectl for this course, it is in the list for other courses so it is being a little over ambitious. In other words you can install it but you are fine anyway

  • Thanks Dr. Jerry for instant & continuous help.

    I have tried multiple things till it worked, just sharing my experience that might be useful to ready-for.sh maintainer.

    This Linux family is important for me as it is used by my corporate and is most commonly used in my region.

    I installed "Fedora 35 Workstation": Script worked fine without an issue.

    I installed "CentOS Stream 8 20220414": As CentOS 8 got removed from all repositories by end of year 2021, It issued two errors for these packages:

    Error: No matching repo to modify: PowerTools.
    WARN: Some packages are missing
    Last metadata expiration check: 0:10:34 ago on Fri 22 Apr 2022 05:33:05 AM +03.
    No match for argument: texinfo
    Dependencies resolved.
    Nothing to do.
    Complete!
    WARN: Some packages didn't install: texinfo
    You can perhaps try installing by running:
    
    

    I had Red Hat Enterprise Linux 8.5: I got the following two error:

    Error: No matching repo to modify: PowerTools.
    WARN: Some packages are missing
    Updating Subscription Management repositories.
    Last metadata expiration check: 1:46:16 ago on Fri 22 Apr 2022 04:10:05 AM +03.
    No match for argument: collectl
    Package pcp-system-tools-5.3.1-5.el8.x86_64 is already installed.
    Dependencies resolved.
    Nothing to do.
    Complete!
    WARN: Some packages didn't install: collectl
    dstat
    
    
  • coop
    coop Posts: 844

    texinfo is also a "Powertools" package on centos-8-stream; however in the LF VM it is turned off because red hat has done a sloppy job and when it is turned on it sometimes causes dependency screw ups. If you turn it on and just install texinfo it should work.

    As far as RHEL 8 in general, RHEL 8 is hit or miss for ready-for.sh because we have almost no students using it in introductory courses at least, as it is not free (although you can get free subscriptions for personal use) and there are tools such as pkgs.org which we use which do not support it. So rather than turn off support, we just don't maintain it well. This is the first case I can remember over a number of years of people raising issues about ready-for.sh and RHEL 8, so I'm sorry if it is a little frustrating.

    You are actually very unlikely to need texinfo, and why it is a required dependency is something frankly I cannot remember. These package lists grow with time, and as distros change sometimes they get somewhat stale. Usually having more packages installed that you need doesn't screw things up, but occasionally you get these kinds of irritations.

  • Thanks for the clear explanation, just sharing my experience. I can understand how it is hard to maintain across multiple distros.

  • coop
    coop Posts: 844

    I actually use real RHEL 8 as my day-to-day workstation (I have been doing so for many years and I'm just used to it) as I personally prefer the rpm world to apt and I find Fedora too volatile though very nice and the C(8,9) stream packages not stable enough for my day to day taste. So that is probably the way we best debug support, through me personally :)

  • "RHEL 8 as day-to-day workstation" this is quite strange, I have only seen this with a friend of mine who is a regional director in Red Hat 😊

    So, you won't bother with my questions about RHEL 😉

  • coop
    coop Posts: 844

    I'll be happy to answer RHEL 8 quesitons, that is not a problem, if I have the knowledge.

Categories

Upcoming Training