Welcome to the Linux Foundation Forum!

Lab 7.2 myingress-ingress-nginx-controller pods were not created

At step 15, when running:
kubectl get pod --all-namespaces |grep nginx

I do not get any pods running for the nginx controller:
myingress-ingress-nginx-controller-...


I was able to install the ingress-nginx helm chart successfully:
"
The ingress-nginx controller has been installed.
It may take a few minutes for the LoadBalancer IP to be available.
You can watch the status by running 'kubectl --namespace default get services -o wide -w myingress-ingress-nginx-controller'
"
and when running the command to check the status I am getting back the nginx-controller services successfully.

But still no nginx-controller pods...


Also after creating the ingress resource in step 17 by:
kubectl create -f ingress.yaml
The pods are still not displayed so I am not able to curl to the pod ip.

Would appreciate help on this

Comments

  • chrispokorni
    chrispokorni Posts: 1,613

    Hi @liorzivi,

    Is there a myingress-ingress-nginx-controller operator running in your cluster? One of the following commands should return the resource if available:

    kubectl get deploy myingress-ingress-nginx-controller

    kubectl get ds myingress-ingress-nginx-controller

    Regards,
    -Chris

Categories

Upcoming Training