Welcome to the Linux Foundation Forum!

Superblock could not be read or does not describe valid ext2 filesystem for /


Hi all,
It's been a while since i have had to mess with redhat and I think I am just missing something to recover this system. It's an old customer of mine. He is moving the system to his house for accounting purposes while shutting down the business now that he retired. I shut the system down normally and got the above error upon reboot. I have no idea when his last backup was.

Running RH enterprise ES 2.6.9-5ELsmp.

on the boot screen it says that it cannot read the superblock and that it cannot mount "/" because "/" is a directory and it dumps me to the maint login and suggest that I run e2fsck

Logged in as root, if I run e2fsck -p /dev/mapper/VolGroup00-LogVol00 is says it's clean but I get dropped to the main login again.

Then I ran dumpe2fs to get all the copies of the superblock and run the e2fsck -b {superblock number} and it makes a bunch of corrections but it does not reboot correctly after and I'm back to the same place.

Am I getting this error because at the maint level the / filesystem in readonly and the changes that the alternate superblock makes are never written and i need to boot from some kind of RH boot cd and run e2fsck -b to get the changes written or is this system really hosed. This system was up and running fine with all applications running before I shut it down with the shutdown command.

Any help would be greatly appreciated.


Upcoming Training