Welcome to the Linux Foundation Forum!

vagrant machine is up but can't access GUI

I am not able to access the GUI for LFS267 course. Machine is up but when accessing gui it gives below error-

The connection was reset

The connection to the server was reset while the page was loading.

The site could be temporarily unavailable or too busy. Try again in a few moments.
If you are unable to load any pages, check your computer’s network connection.
If your computer or network is protected by a firewall or proxy, make sure that Firefox is permitted to access the Web.

Answers

  • Is port 5000 blocked or already in use on your machine?

    Also, what is your OS? What VirtualBox and vagrant version are you using?

  • Ravirai
    Ravirai Posts: 12

    I was able to access the day before. I am running in Macos.

    vagrant version
    Installed Version: 2.2.19
    Latest Version: 2.2.19

    You're running an up-to-date version of Vagrant!

    VirtualBox version 6.1

  • Ravirai
    Ravirai Posts: 12

    i tried just now and below is vagrant machines status-

    vagrant up
    Bringing machine 'default' up with 'virtualbox' provider...
    ==> default: Clearing any previously set forwarded ports...
    ==> default: Clearing any previously set network interfaces...
    ==> default: Preparing network interfaces based on configuration...
    default: Adapter 1: nat
    ==> default: Forwarding ports...
    default: 5000 (guest) => 5000 (host) (adapter 1)
    default: 22 (guest) => 2222 (host) (adapter 1)
    ==> default: Booting VM...
    ==> default: Waiting for machine to boot. This may take a few minutes...
    default: SSH address: 127.0.0.1:2222
    default: SSH username: vagrant
    default: SSH auth method: private key
    ==> default: Machine booted and ready!
    ==> default: Checking for guest additions in VM...
    ==> default: Machine already provisioned. Run vagrant provision or use the --provision
    ==> default: flag to force provisioning. Provisioners marked to run always will still run.
    [email protected] lfs267-lab-resources %
    [email protected] lfs267-lab-resources %
    [email protected] lfs267-lab-resources % vagrant status
    Current machine states:

    default running (virtualbox)

    The VM is running. To stop this VM, you can run vagrant halt to
    shut it down forcefully, or you can run vagrant suspend to simply
    suspend the virtual machine. In either case, to restart it again,
    simply run vagrant up.

  • Ravirai
    Ravirai Posts: 12

    I see this for ports-

    tcp4 0 0 127.0.0.1.2222 . LISTEN 65536 65536 7416 0 0x0100 0x00000106
    tcp4 0 0 127.0.0.1.5000 . LISTEN 65536 65536 7416 0 0x0100 0x00000106

  • Ravirai
    Ravirai Posts: 12

    lsof -Pn -i4 | grep LISTEN
    inSync 755 ravirai 11u IPv4 0x101a4415503621f5 0t0 TCP 127.0.0.1:7010 (LISTEN)
    inSync 755 ravirai 28u IPv4 0x101a44154f8814bd 0t0 TCP 127.0.0.1:49462 (LISTEN)
    inSync 755 ravirai 29u IPv4 0x101a4415503174bd 0t0 TCP 127.0.0.1:49463 (LISTEN)
    Python 777 ravirai 3u IPv4 0x101a44154e742d5d 0t0 TCP 127.0.0.1:5353 (LISTEN)
    VBoxHeadl 7416 ravirai 16u IPv4 0x101a44154c37c645 0t0 TCP 127.0.0.1:5000 (LISTEN)
    VBoxHeadl 7416 ravirai 17u IPv4 0x101a441557be590d 0t0 TCP 127.0.0.1:2222 (LISTEN)

  • And you are still unable to access the UI?

    http://localhost:5000

    Given that you would access it before, it is most likely issue with the state of this vm. You can always destroy it and recreate it.

    Once issue we have seen on MacOS Monterey, a new process is using port 5000 and it interferes with vagrant port.

    https://developer.apple.com/forums/thread/682332

    You can disable that based on above instructions.

  • Ravirai
    Ravirai Posts: 12

    I am on Big Sur version 11.6.
    I am trying to destroy and restore same box.

  • Ravirai
    Ravirai Posts: 12
    edited March 21

    it worked. For anyone , who might come to this scenario . i took backup of box and vagrant file. Destroyed existing box and vagrant file. And added back the box and vagrant backup then started the machine. Below link might be useful-

    https://www.webfoobar.com/node/52

    But it starts from beginning(scratch)!

Categories

Upcoming Training