Welcome to the Linux Foundation Forum!

k8scp.sh and k8sWorker.sh are not getting downloaded

bvssnraju Posts: 4
edited March 2022 in LFD259 Class Forum

Could someone help with this?

$ wget https://training.linuxfoundation.org/cm/LFD259/LFD259V2022-02-25SOLUTIONS.tar.xz --user= --password=
--2022-03-18 20:16:55-- https://training.linuxfoundation.org/cm/LFD259/LFD259V2022-02-25SOLUTIONS.tar.xz
Resolving training.linuxfoundation.org (training.linuxfoundation.org)...
Connecting to training.linuxfoundation.org (training.linuxfoundation.org)||:443... connected.
HTTP request sent, awaiting response... 401 Restricted
Authentication selected: Basic realm="Linux Training"
Connecting to training.linuxfoundation.org (training.linuxfoundation.org)||:443... connected.
HTTP request sent, awaiting response... 404 Not Found
2022-03-18 20:16:56 ERROR 404: Not Found.


  • bvssnraju

    Same issue when opening the url in browser

  • coop
    coop Posts: 915


    Is the correct link as noted above. cutting and pasting underscores from PDF's leads to many errors of this type. Note that you can always just point your browser to https://training.linuxfoundation.org/cm/LFD259 and download through a gui, or just do a wget to the whole directory (it is small) specifying the password and username you already have.

    And we do understand that there are students who have problems with this, and no matter how hard we try, they are a few enrollees of the thousands who navigate this successfully and so say nothing. One solution I can think of is to use bitly links in the material, but that presents a problem in production of the material with them going stale as the version number is encoded in the name, and I can tell you that the same problem will develop elsewhere in places where there are no URLs, but in command line things.

    Learning to be careful about what you type is part of the process of working at the command line I'm afraid, and whenever there are long jibberishy things to type, the course authors strive to provide downloadable scripts etc that can easily be used and cut and paste from.

  • akovi
    akovi Posts: 16

    @coop As in this case the underscores seem to be the only problem (as @TBBle fellow student wisely debugged it), the obvious solution would be to simply remove the underscores, isn't it? It is even a larger issue that clicking the link, in new tab or otherwise, doesn't work either, the the hyperlink itself is erroneous. And to add to that, the HTTP 404 doesn't obviously say what is wrong. There are like a gazillion other ways to improve the UX with this issue and I can't believe that any of them would be a huge undertaking.

    This issue arises very early in the course and honestly, it's infuriating. For the exact reason you mention, typing URLs is error prone, it should be avoided as much as possible.

  • bvssnraju

    worked by copying the file name manually from

  • chrispokorni
    chrispokorni Posts: 2,221

    Hi @bvssnraju,

    Glad it all worked out.

    For future reference, however, sharing sensitive information, such as user ID and password, in a forum is highly discouraged.



Upcoming Training