Permission Denied: curl -sSL http://bit.ly/2ysbOFE | bash -s -- 2.2.2 1.4.9
I am trying to complete the Lab Setup for the Hyperledger Fabric training and facing issues. I am running Ubuntu and have followed the Setup instructions to the "T". I am also totally new to Linux so these errors are confusing for me and I am not sure how to resolve them. I have pasted the output of the command that I ran. Primarily, I am getting several Permission Denied Errors and that could be the cause of the error I am getting when running the very last command which is:
faruk@HLFT-VirtualBox:~/go/src/github.com/hyperledger/fabric-samples/test-network$ sudo ./network.sh up createChannel -ca -s couchdb
I get the following error:
ERROR: The Compose file './docker/docker-compose-ca.yaml' is invalid because:
networks.test value Additional properties are not allowed ('name' was unexpected).
I am unable to proceed any further. Any help would be greatly appreciated. Thank you in advance.
faruk@HLFT-VirtualBox:~/go/src/github.com/hyperledger$ curl -sSL http://bit.ly/2ysbOFE | bash -s -- 2.2.2 1.4.9
Pull Hyperledger Fabric docker images
FABRIC_IMAGES: peer orderer ccenv tools baseos
===> Pulling fabric Images
====> hyperledger/fabric-peer:2.2.2
Got permission denied while trying to connect to the Docker daemon socket at unix:///var/run/docker.sock: Post "http:///var/run/docker.sock/v1.24/images/create?fromImage=hyperledger/fabric-peer&tag=2.2.2": dial unix /var/run/docker.sock: connect: permission denied
Got permission denied while trying to connect to the Docker daemon socket at unix:///var/run/docker.sock: Post "http:///var/run/docker.sock/v1.24/images/hyperledger/fabric-peer:2.2.2/tag?repo=hyperledger/fabric-peer&tag=latest": dial unix /var/run/docker.sock: connect: permission denied
Got permission denied while trying to connect to the Docker daemon socket at unix:///var/run/docker.sock: Post "http:///var/run/docker.sock/v1.24/images/hyperledger/fabric-peer:2.2.2/tag?repo=hyperledger/fabric-peer&tag=2.2": dial unix /var/run/docker.sock: connect: permission denied
====> hyperledger/fabric-orderer:2.2.2
Got permission denied while trying to connect to the Docker daemon socket at unix:///var/run/docker.sock: Post "http:///var/run/docker.sock/v1.24/images/create?fromImage=hyperledger/fabric-orderer&tag=2.2.2": dial unix /var/run/docker.sock: connect: permission denied
Got permission denied while trying to connect to the Docker daemon socket at unix:///var/run/docker.sock: Post "http:///var/run/docker.sock/v1.24/images/hyperledger/fabric-orderer:2.2.2/tag?repo=hyperledger/fabric-orderer&tag=latest": dial unix /var/run/docker.sock: connect: permission denied
Got permission denied while trying to connect to the Docker daemon socket at unix:///var/run/docker.sock: Post "http:///var/run/docker.sock/v1.24/images/hyperledger/fabric-orderer:2.2.2/tag?repo=hyperledger/fabric-orderer&tag=2.2": dial unix /var/run/docker.sock: connect: permission denied
====> hyperledger/fabric-ccenv:2.2.2
Got permission denied while trying to connect to the Docker daemon socket at unix:///var/run/docker.sock: Post "http:///var/run/docker.sock/v1.24/images/create?fromImage=hyperledger/fabric-ccenv&tag=2.2.2": dial unix /var/run/docker.sock: connect: permission denied
Got permission denied while trying to connect to the Docker daemon socket at unix:///var/run/docker.sock: Post "http:///var/run/docker.sock/v1.24/images/hyperledger/fabric-ccenv:2.2.2/tag?repo=hyperledger/fabric-ccenv&tag=latest": dial unix /var/run/docker.sock: connect: permission denied
Got permission denied while trying to connect to the Docker daemon socket at unix:///var/run/docker.sock: Post "http:///var/run/docker.sock/v1.24/images/hyperledger/fabric-ccenv:2.2.2/tag?repo=hyperledger/fabric-ccenv&tag=2.2": dial unix /var/run/docker.sock: connect: permission denied
====> hyperledger/fabric-tools:2.2.2
Got permission denied while trying to connect to the Docker daemon socket at unix:///var/run/docker.sock: Post "http:///var/run/docker.sock/v1.24/images/create?fromImage=hyperledger/fabric-tools&tag=2.2.2": dial unix /var/run/docker.sock: connect: permission denied
Got permission denied while trying to connect to the Docker daemon socket at unix:///var/run/docker.sock: Post "http:///var/run/docker.sock/v1.24/images/hyperledger/fabric-tools:2.2.2/tag?repo=hyperledger/fabric-tools&tag=latest": dial unix /var/run/docker.sock: connect: permission denied
Got permission denied while trying to connect to the Docker daemon socket at unix:///var/run/docker.sock: Post "http:///var/run/docker.sock/v1.24/images/hyperledger/fabric-tools:2.2.2/tag?repo=hyperledger/fabric-tools&tag=2.2": dial unix /var/run/docker.sock: connect: permission denied
====> hyperledger/fabric-baseos:2.2.2
Got permission denied while trying to connect to the Docker daemon socket at unix:///var/run/docker.sock: Post "http:///var/run/docker.sock/v1.24/images/create?fromImage=hyperledger/fabric-baseos&tag=2.2.2": dial unix /var/run/docker.sock: connect: permission denied
Got permission denied while trying to connect to the Docker daemon socket at unix:///var/run/docker.sock: Post "http:///var/run/docker.sock/v1.24/images/hyperledger/fabric-baseos:2.2.2/tag?repo=hyperledger/fabric-baseos&tag=latest": dial unix /var/run/docker.sock: connect: permission denied
Got permission denied while trying to connect to the Docker daemon socket at unix:///var/run/docker.sock: Post "http:///var/run/docker.sock/v1.24/images/hyperledger/fabric-baseos:2.2.2/tag?repo=hyperledger/fabric-baseos&tag=2.2": dial unix /var/run/docker.sock: connect: permission denied
===> Pulling fabric ca Image
====> hyperledger/fabric-ca:1.4.9
Got permission denied while trying to connect to the Docker daemon socket at unix:///var/run/docker.sock: Post "http:///var/run/docker.sock/v1.24/images/create?fromImage=hyperledger/fabric-ca&tag=1.4.9": dial unix /var/run/docker.sock: connect: permission denied
Got permission denied while trying to connect to the Docker daemon socket at unix:///var/run/docker.sock: Post "http:///var/run/docker.sock/v1.24/images/hyperledger/fabric-ca:1.4.9/tag?repo=hyperledger/fabric-ca&tag=latest": dial unix /var/run/docker.sock: connect: permission denied
Got permission denied while trying to connect to the Docker daemon socket at unix:///var/run/docker.sock: Post "http:///var/run/docker.sock/v1.24/images/hyperledger/fabric-ca:1.4.9/tag?repo=hyperledger/fabric-ca&tag=1.4": dial unix /var/run/docker.sock: connect: permission denied
===> List out hyperledger docker images
Got permission denied while trying to connect to the Docker daemon socket at unix:///var/run/docker.sock: Get "http:///var/run/docker.sock/v1.24/images/json": dial unix /var/run/docker.sock: connect: permission denied
Comments
-
See other posts about installing docker-compose. It's a nightmare. Pre-req instructions are out of date and they refuse to update them. apt-get method installs the wrong version of docker-compose. Some say the best way to install it is by installing Docker Desktop: https://docs.docker.com/compose/install/compose-desktop/
0 -
@farukansari, Hello, Let's see if we can get to the bottom of this. The pre-requisite instructions are continually being looked at and updated as the versions of Docker are improved and upgraded. In some cases, they are out of sync. Have you tried installing Docker Desktop with the command: https://docs.docker.com/compose/install/compose-desktop/ as suggested by king612? Bobbi
0
Categories
- All Categories
- 178 LFX Mentorship
- 178 LFX Mentorship: Linux Kernel
- 775 Linux Foundation IT Professional Programs
- 384 Cloud Engineer IT Professional Program
- 175 Advanced Cloud Engineer IT Professional Program
- 75 DevOps IT Professional Program - Discontinued
- 7 DevOps & GitOps IT Professional Program
- 103 Cloud Native Developer IT Professional Program
- 7.6K Training Courses & Learning Paths
- 13 AI & ML Training
- 1 Blockchain & Decentralized Identity Training
- 34 Cloud & Containers Training
- 3 Cybersecurity Training
- 3 DevOps & Site-Reliability Training
- 2 Linux Kernel Development Training
- 2 Networking Training
- 2 Open Source Best Practice Training
- 5 System Administration Training
- 1 System Engineering Training
- 6 Web & Application Development Training
- 798 Hardware
- 202 Drivers
- 68 I/O Devices
- 37 Monitors
- 96 Multimedia
- 173 Networking
- 91 Printers & Scanners
- 92 Storage
- 772 Linux Distributions
- 81 Debian
- 68 Fedora
- 24 Linux Mint
- 13 Mageia
- 24 openSUSE
- 151 Red Hat Enterprise
- 31 Slackware
- 13 SUSE Enterprise
- 356 Ubuntu
- 470 Linux System Administration
- 31 Cloud Computing
- 73 Command Line/Scripting
- Github systems admin projects
- 101 Linux Security
- 79 Network Management
- 102 System Management
- 46 Web Management
- 166 Mobile Computing
- 32 Android
- 119 Development
- 1.2K New to Linux
- 1K Getting Started with Linux
- 407 Off Topic
- 128 Introductions
- 35 Study Material
- 1.1K Programming and Development
- 310 Kernel Development
- 722 Software Development
- 1K Software
- 418 Applications
- 182 Command Line
- 5 Compiling/Installing
- 71 Games
- 320 Installation
- Archived
- 183 Small Talk
- 2 LFD140 Class Forum
- 1.4K LFS258 Class Forum
Upcoming Training
-
August 20, 2018
Kubernetes Administration (LFS458)
-
August 20, 2018
Linux System Administration (LFS301)
-
August 27, 2018
Open Source Virtualization (LFS462)
-
August 27, 2018
Linux Kernel Debugging and Security (LFD440)
