Welcome to the Linux Foundation Forum!

Lab 2.2 - Failing to work

I have run through the aws setup.

I went through the setup steps depicted here.

Configured everything appropriately, including running swapoff -a; however, after I ssh into my instance and attempt to run the lab with this command bash k8scp.sh | tee $HOME/cp.out, I get the following output:

The following information may help to resolve the situation:

The following packages have unmet dependencies:
 buildah : Depends: crun (>= 100:0.18-3) but it is not going to be installed
 cri-o-runc : Depends: libc6 (>= 2.28) but 2.27-3ubuntu1.5 is to be installed
 podman : Depends: crun (>= 100:0.19.1-1) but it is not going to be installed
          Recommends: containernetworking-plugins (>= 100:1.0.0-1) but it is not going to be installed
          Recommends: fuse-overlayfs but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
sed: can't read /etc/containers/storage.conf: No such file or directory
Failed to enable unit: Unit file crio.service does not exist.
Failed to start crio.service: Unit crio.service not found.
Warning: apt-key output should not be parsed (stdout is not a terminal)

I'm running t2.large in AWS with 2 CPU, 8 GB RAM.
I'm able to SSH into my AWS instance.
I'm able to curl the project files in my AWS instance.
I'm not able to run bash k8scp.sh | tee $HOME/cp.out.

I have spent many hours attempting to run this lab in a variety of environments (virtual box, now AWS), all with the same result. I am absolutely spinning my wheels, any help would be appreciated..

Comments

  • akovi
    akovi Posts: 16

    Do you use the Ubuntu Focal image? Your output kinda suggests that the base system is not the right version.

    I installed it a few days ago. (After figuring out the quirk with the course material URL, it worked fine.)

    I used this Vagrant file:

    Vagrant.configure("2") do |config|
      config.vm.provider "virtualbox" do |provider|
        provider.gui = false
        provider.memory = 8192
      end
      config.vm.network "public_network"
      config.vm.box = "ubuntu/focal64"
      config.vm.define "vm1" do |node|
        node.vm.hostname = "vm1"
        node.vm.network :private_network, ip: "10.110.0.100"
      end
      config.vm.define "vm2" do |node|
        node.vm.hostname = "vm2"
        node.vm.network :private_network, ip: "10.110.0.200"
      end
      config.vm.provision "shell",    inline: <<-EOF
      set -ex
      sudo apt-get update
      sudo apt-get install policycoreutils selinux-utils selinux-basics -y
      sudo setenforce 0 || :
      sudo swapoff -a || :
    EOF
    end
    

    After the vagrant up, I
    1. used vagrant ssh-config to get the ssh connection config
    2. stopped the machines
    3. disabled Adapter 1 in the machine settings for both vm1 and vm2
    4. then started the machines manually.

    Step 3 is necessary as otherwise the TLS certificate of the api-server will be invalid (Not contain the IP you need). Alternatively, you may try to modify the k8scp.sh script but I didn't have to do that this way.

    Following this, you should be able to follow the tutorial to install the cluster.

  • chrispokorni
    chrispokorni Posts: 1,458

    Hi @dillonjcooper2,

    Would you be able to confirm that the EC2 instances are running Ubuntu 20.04 LTS?

    Regards,
    -Chris

Categories

Upcoming Training