Welcome to the Linux Foundation Forum!

Lab 8.1 Error: endorsement failure during invoke

Hello,

I am running into an issue right after setting up all my exports lab 8.
I try to run:
"peer chaincode invoke ${orderer} -C mychannel -n balance_transfer ${peer_org1} ${peer_org2} -c '{"function":"initAccount","Args":["A1","100"]}'"
but get the error message:

Error: endorsement failure during invoke. response: status:500 message:"error in simulation: failed to execute transaction c39520409194e62eb2d103be52603bbb29bf715cd40eb2b536daa3561afd167a: could not launch chaincode balance_transfer_1.0:1ad31749a5e1e2ccee223d6520dbaa4f1c7dae7fa1f177259ea77c0b23659eb6: error starting container: error starting container: API error (404): network _test not found"

Everything seemed to be working fine until running into this.
Was wondering if anyone ran into a similar issue and what they did to fix it.

Thanks

Answers

  • basilky
    basilky Posts: 6

    I had faced this issue sometimes back. This was due to some issue with the n/w name created by docker. This fix should be resolving the issue( fabric-samples v2.2.2 is having this fix).

  • ThomasRitter
    ThomasRitter Posts: 2
    edited March 21

    Hello @basilky,

    Thank you for your help here. There is a team of 4 that are going through this including Chris that are experiencing this issue. The team did attempt to go through the fix mentioned, but still experiencing the same error. We were wondering if it might be an issue with naming consistency with what has been written so far.

    Any further insights and/or recommendations would be greatly appreciated.

    Kind Regards,
    Tom R.

  • cdervan
    cdervan Posts: 2

    Thanks for the responses,

    I've been using the fabric-samples v2.2.2 and I am still running into this error.

    Is the fix that is linked above, specifically telling me to remove my env variables and edit some specific config/yaml file to include the name test _network, or is this supposed to already be done through the new version?

    It seems like there is some sort of naming inconsistency but I am not sure what is calling network _test and where to change/fix it.

    Thanks again,

  • Bobbijn
    Bobbijn Posts: 148
    edited March 22

    @cdervan, @basilky. @ThomasRitter ,
    Hello, I have been looking into this issue and I am not finding a simple resolve for it. I have posted the issue in the Hyperledger Discord Channel for Fabric private Chaincode.
    Here is an invite to the discord channel https://discord.gg/cScjFdtN. Hopefully this will get the conversation headed in the right direction. Talk soon, Bobbi

  • ThomasRitter
    ThomasRitter Posts: 2
    edited April 12

    @Bobbijn @basilky
    This issue was resolved by recommendations to test different packages made for functions that are most well associated with the intended outcomes from our project. Thank you Bobbi, basilky, and the overall Hyperledger developer community for your support in resolving this. This is truly a great developer community!

    To summarize, it was a misconception on which package we needed for the test function to operate properly. The one that worked in this test scenario was the ERC20 chaincode, link below.
    https://github.com/hyperledger/fabric-samples/tree/main/token-erc-20

  • Bobbijn
    Bobbijn Posts: 148

    :)

Categories

Upcoming Training