Welcome to the Linux Foundation Forum!

Lab 2.1 Error when spinning up network

Hi, I followed the steps but met the following error when trying to start the test network. Any idea on how to deal with this issue or the "name" property? Thank a lot.

./network.sh up createChannel -ca -s couchdb

ERROR: The Compose file './docker/docker-compose-test-net.yaml' is invalid because:
networks.test value Additional properties are not allowed ('name' was unexpected)

Best Answers

  • goosecoder
    goosecoder Posts: 2
    Answer ✓

    Got the same error, for me it worked after I uninstalled the docker-compose version from the ubuntu repositories (which is recommended by the course by the way) and installed the official one from this link: https://docs.docker.com/compose/install/.

  • Bobbijn
    Bobbijn Posts: 190
    Answer ✓


  • jfpadilla
    jfpadilla Posts: 4
    edited March 2022 Answer ✓

    thanks for confirming. no worries I've setup the environment before so it's easier for me to use mac. I wanted to use the ubuntu on my windows for the lab exercises to follow every step but it's just not working consistently on my windows machine. So will use mac instead for the remaining lab exercises. thanks again for confirming. :)


  • I get the same issue. I think there is an issue in the setup instructions - the ...-tools folder is missing for me. I think the initial install misses some things?

  • @Bobbijn Can you help on this please. Several students are reporting the same issue. Thanks.

  • I go t a little further googling the error message and found this:

    "just open terminal and type this command

    sudo chmod 666 /var/run/docker.sock"

    This got me further (along with running everything sudo), but now when I start the test network I get:

    "Error: failed to create deliver client for orderer: orderer client failed to connect to localhost:7050: failed to create new connection: connection error: desc = "transport: error while dialing: dial tcp connect: connection refused"

    The installation guide appears to be poorly written and out of date.

    I think a lot of sudo aggravation can be saved by following this link from the install guide:


  • Bobbijn
    Bobbijn Posts: 190

    Thanks for looking into this issue. The course information is always being update. Any suggestion to improve the text is always welcome and will brought to the attention of the course authors. Bobbi

  • Bobbijn
    Bobbijn Posts: 190

    Thank you for this feedback, the course authors are looking into this issue and will update the course accordingly. Any insights would be appreciated as we value your input. Bobbi

  • Hi not sure if this is the right post to comment on but would it be possible to skip using virtual machine (windows laptop) for the lab exercises. because my ubuntu is not working consistently. can I just use my mac instead (no setup of virtual box, ubuntu) but I have installed other dependencies like docker, node, etc? Is this approach ok and I can start the fabric network there with ease compared to my windows(virtual box). thanks in advance!

  • Hi jfpadilla, I think the guide does allow one to use other set-ups than virtual machines, and it lists some options. But it says if you choose to use host machine you would need to do so at your own risk, because it cannot guarantee the commands in the steps will not break your computer. Using virtual machines has the benefit of easily starting everything over without doing harm to your host machine. I think that makes sense.

  • basilky
    basilky Posts: 6

    This issue seems to come because of old docker version. I was able to work around this by incrementing the version property in docker compose files to version: '3.7'


Upcoming Training