Welcome to the Linux Foundation Forum!

Unable to install openstack

2»

Comments

  • raghuramg
    raghuramg Posts: 70

    Hi @michaober,
    FYI. Currently, ONAP Lab is currently broken due to certificate expiry in ONAP Guilin (Current LAB is based on Guilin).
    We are in the process of upgrading ONAP Labs from Guilin to Istnabul.

  • michaober
    michaober Posts: 12

    Here are the steps to install OpenStack.

    No, those instructions are incomplete. If I log in using gcloud compute ssh --zone "us-central1-f" "openstack-01", there is no "onap-custom" directory.

  • raghuramg
    raghuramg Posts: 70
    edited March 24

    Hi @michaober,
    The folder is in the aarna user home directory.
    # sudo su aarna
    # cd
    # ls
    You will find the folder.

  • michaober
    michaober Posts: 12

    I cannot run sudo bash -x aio-ubuntu-gcp-deploy.sh 2 because it requires to enter the password for user "aarna"

  • raghuramg
    raghuramg Posts: 70

    Hi @michaober,
    Please share your VM IP.

  • michaober
    michaober Posts: 12
    edited March 24

    Please provide accurate and complete instructions.

  • raghuramg
    raghuramg Posts: 70

    Hi @michaober@michaober

    Those are the accurate instructions and tested. It is working fine for us and for other LFN users.

    Another option is to login directly to aarna login using aarna private key. If you don't have a key I can share.

  • michaober
    michaober Posts: 12

    Those are the accurate instructions and tested.

    If you execute the commands you posted, you don't have to enter a sudo-password for user aarna when executing the command sudo bash -x aio-ubuntu-gcp-deploy.sh 2?

  • raghuramg
    raghuramg Posts: 70

    Yes. Correct. You have to execute all the posted commands from aarna user.

  • michaober
    michaober Posts: 12

    But how is it possible you don't have to enter a password when running sudo? Did you modify the sudoers file?

  • raghuramg
    raghuramg Posts: 70

    aarna is added to sudoers group and hence it is not required to enter a password.

    In your earlier VM yesterday. You were able to run the script right?. it is the same image. I hope you were able to run the script from aarna user only?

  • michaober
    michaober Posts: 12

    aarna is added to sudoers group and hence it is not required to enter a password.

    No. This is wrong.

    I just created a new VM using:

    gcloud compute instances create openstack-01 --zone us-central1-f --custom-cpu 32 --custom-memory 72GB --min-cpu-platform "Intel Haswell" --image "https://www.googleapis.com/compute/v1/projects/onap-177920/global/images/aarna-aio-openstack-victoria-ubuntu-20-16032022-00"

    Then I connected via SSH using:

    gcloud compute ssh --zone "us-central1-f" "openstack-01"

    Then I enter the following commands:

    [email protected]:~$ sudo su aarna
    [email protected]:/home/Micha$ cd
    [email protected]:~$ ls
    onap-custom
    [email protected]:~$ sudo -l
    [sudo] password for aarna:

    As you can see, a password is required for the sudo command. The "aarna" user is not in the sudoers file. Please stop claiming it is.

  • raghuramg
    raghuramg Posts: 70

    Hi @michaober,

    I have run the same steps and it working as expected. If you would like us to fix it. please share your VM IP.

    [email protected]:~/Desktop/Aarna-Networks/mykeys$ gcloud compute instances create openstack-01 --zone us-central1-f --custom-cpu 32 --custom-memory 72GB --min-cpu-platform "Intel Haswell" --image "https://www.googleapis.com/compute/v1/projects/onap-177920/global/images/aarna-aio-openstack-victoria-ubuntu-20-16032022-00"

    [email protected]:~/Desktop/Aarna-Networks/mykeys$ gcloud compute ssh --zone=us-central1-f openstack-01

    [email protected]:~$ sudo su aarna
    [email protected]:/home/raghuram$ cd
    [email protected]:~$ ls
    onap-custom
    [email protected]:~$ sudo -l
    Matching Defaults entries for aarna on openstack-01:
    env_reset, mail_badpass, secure_path=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/snap/bin

    User aarna may run the following commands on openstack-01:
    (ALL : ALL) NOPASSWD: ALL

    I can do sudo su without password
    [email protected]:~$sudo su
    [email protected]:/home/aarna#

  • raghuramg
    raghuramg Posts: 70

    hi @michaober,
    Alternatively, you can download the aarna.pem file from the link I shared with you in the message and login to aarna user.

    Another option is to execute the below command from your login or root login to add aarna user to sudo group.
    sudo usermod -aG sudo aarna

Categories

Upcoming Training