Welcome to the Linux Foundation Forum!

Lab 4.5 Install CRI-IO: installation issues

Hi All, I am having issues with the following steps:

[email protected]:~# curl -L https://download.opensuse.org/repositories/devel:kubic:libcontainers:stable:cri-o:$VERSION/$OS/Release.key | apt-key add -
% Total % Received % Xferd Average Speed Time Time Time Current
Dload Upload Total Spent Left Speed
100 375 100 375 0 0 1129 0 --:--:-- --:--:-- --:--:-- 1129
100 376 100 376 0 0 872 0 --:--:-- --:--:-- --:--:-- 872
100 377 100 377 0 0 711 0 --:--:-- --:--:-- --:--:-- 711
100 378 100 378 0 0 600 0 --:--:-- --:--:-- --:--:-- 600
100 1083 0 1083 0 0 1483 0 --:--:-- --:--:-- --:--:-- 1483
gpg: no valid OpenPGP data found.

[email protected]:~# curl -L https://download.opensuse.org/repositories/devel:/kubic:/libcontainers:/stable/$OS/Release.key | apt-key add -
% Total % Received % Xferd Average Speed Time Time Time Current
Dload Upload Total Spent Left Speed
100 1083 0 1083 0 0 2349 0 --:--:-- --:--:-- --:--:-- 2349
gpg: no valid OpenPGP data found.

Subsequently apt update fails:

[email protected]:~$ sudo apt update
Hit:1 http://us-east1.gce.archive.ubuntu.com/ubuntu focal InRelease
Hit:2 http://us-east1.gce.archive.ubuntu.com/ubuntu focal-updates InRelease
Hit:3 http://us-east1.gce.archive.ubuntu.com/ubuntu focal-backports InRelease
Hit:4 https://download.docker.com/linux/ubuntu focal InRelease
Get:5 http://security.ubuntu.com/ubuntu focal-security InRelease [114 kB]
Ign:6 http://download.opensuse.org/repositories/devel:/kubic:/libcontainers:/stable:/crio:/1.23/ InRelease
Err:7 http://download.opensuse.org/repositories/devel:/kubic:/libcontainers:/stable:/crio:/1.23/ Release
404 Not Found [IP: 195.135.221.134 80]
Ign:8 https://download.opensuse.org/repositories/devel:/kubic:/libcontainers:/stable/ InRelease
Err:9 https://download.opensuse.org/repositories/devel:/kubic:/libcontainers:/stable/ Release
404 Not Found [IP: 195.135.221.134 443]
Reading package lists... Done
E: The repository 'http://download.opensuse.org/repositories/devel:/kubic:/libcontainers:/stable:/crio:/1.23/ Release' does not have a Release file.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.
E: The repository 'https://download.opensuse.org/repositories/devel:/kubic:/libcontainers:/stable/ Release' does not have a Release file.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.

I am using Ubuntu 20.04. I have tried with other CRI-IO versions but same issue. Also I have reviewed other threads related to lab 4.5, but they seem to refer to different issues.

Comments

Categories

Upcoming Training