Welcome to the Linux Foundation Forum!

Failing to enable includes | Lab 8.4

Hi guys,

I'm following Lab8.4's solution to the letter but I get an error occurred while processing this directive:

My /magic/index.html URI is located at /var/www/html/magic/index.html:

..., the includes folder is at /var/www/html/magic/includes:

...and my conf at /etc/apache2/sites-enabled/magic.conf:

I've tried multiple options for the path on the virtual tag of the HTML files, and moving the includes folder to /var/www/html/, but I always get the same error. I'm open to try any possibility that you guys my suggest though.

Thanks a lot for the help!

Answers

  • lee42x
    lee42x Posts: 352

    The magic index.html file lives in /var/www/html/includes/index.html.
    What version of Ubuntu are you using?

    Regards Lee

  • I moved magic index.html to that location you mentioned and now I get a Not Found error.

    But the lab says that magic index.html lives in /var/www/html/magic/index.html

    And I'm using Ubuntu 20.04.3 LTS @lee42x

  • lee42x
    lee42x Posts: 352

    Please confirm the location of foo.html and bar.html.
    Did you use copy and paste creating the files?

  • /var/www/html/magic/includes/bar.html and /var/www/html/magic/includes/foo.html

    I've tried multiples ways: copy/paste directly, manually typing "this is the bar/foo include", surrounding each phrase with <p> tags, but none has worked.

    @lee42x

Categories

Upcoming Training