Welcome to the Linux Foundation Forum!

peer channel list not working

Hi everyone,

I am trying to make work LAB 4.1.

What I am doing.

1) stopping the network

sudo ./network.sh down

**2) starting the network **

sudo ./network.sh up createChannel -ca -s couchdb

3) opening two terminals
4) first terminal run the following

cd $HOME/go/src/github.com/hyperledger/fabric-samples/test-network

export CORE_PEER_TLS_ENABLED=true

export CORE_PEER_LOCALMSPID="Org1MSP"

export CORE_PEER_TLS_ROOTCERT_FILE=${PWD}/organizations/peerOrganizations/org1.example.com/peers/peer0.org1.example.com/tls/ca.crt

export CORE_PEER_MSPCONFIGPATH=${PWD}/organizations/peerOrganizations/org1.example.com/users/[email protected]/msp

export CORE_PEER_ADDRESS=localhost:7051

export PATH=${PWD}/../bin:$PATH

export FABRIC_CFG_PATH=$PWD/../config/

5) second terminal the the following

cd $HOME/go/src/github.com/hyperledger/fabric-samples/test-network

export CORE_PEER_TLS_ENABLED=true

export CORE_PEER_LOCALMSPID="Org2MSP"

export CORE_PEER_TLS_ROOTCERT_FILE=${PWD}/organizations/peerOrganizations/org2.example.com/peers/peer0.org2.example.com/tls/ca.crt

export CORE_PEER_MSPCONFIGPATH=${PWD}/organizations/peerOrganizations/org2.example.com/users/[email protected]/msp

export CORE_PEER_ADDRESS=localhost:9051

export PATH=${PWD}/../bin:$PATH

export FABRIC_CFG_PATH=$PWD/../config/

6)** in terminal one running **

peer channel list

I have the error below

2022-01-26 16:55:13.133 +03 [main] InitCmd -> ERRO 001 Cannot run peer because cannot init crypto, specified path "/home/hassan/go/src/github.com/hyperleger/fabric-samples/test-network/organizations/peerOrganizations/org1.example.com/users/[email protected]/msp" does not exist or cannot be accessed: stat /home/hassan/go/src/github.com/hyperleger/fabric-samples/test-network/organizations/peerOrganizations/org1.example.com/users/[email protected]/msp: permission denied

7) I think I need root user so I run

sudo peer channel list

And I have the error :
sudo: peer: command not found

I've done that many time, I don't know what to do to make it work.

Any suggestion will be most appreciated.

Thanks.
Hassan

Answers

  • It worked when I run the same but before I wrote

    sudo -s

    Is it the good practice to do that ?

  • Bobbijn
    Bobbijn Posts: 149

    @hblockchain, Glad to see you working through this issue. Depending on your system and how its configured, some simple syntax changes can be implemented. Keep on learning and thank you for sharing the solution, it helps other learners with similar issues. Bobbi

  • Thanks Hassan! This worked perfectly for me! :D

  • Bobbijn
    Bobbijn Posts: 149

    :)

Categories

Upcoming Training