Welcome to the Linux Foundation Forum!

getting errors while installing new kernel

viveksahu26
viveksahu26 Posts: 12
edited January 24 in LFD103 Class Forum

As I tried to run the command > sudo bash -c "make modules_install install . I am getting some errors.

$ sudo bash  -c "make modules_install install"
[sudo] password for viveksahu26: 
sed: can't read modules.order: No such file or directory
make[1]: *** [Makefile:1479: _modinst_] Error 2
make: *** [Makefile:335: __build_one_by_one] Error 2

I need help to install new kernel. Anyone will be most welcome for help.

Answers

  • coop
    coop Posts: 882

    Did you do a "make" first? (which builds the kernel and also does "make modules"). You cannot install them if they were not made first

  • viveksahu26
    viveksahu26 Posts: 12
    edited January 24

    Yes, @coop I did.
    I ran these commands:

    make oldconfig
    make LSMOD=/tmp/my-lsmod  localmodconfig
    make -j3 all"
    
  • ShuahKhanLF
    ShuahKhanLF Posts: 121

    It appears kernel build might have failed. Also the sequence of "make oldconfig; make LSMOD=/tmp/my-lsmod localmodconfig;" looks odd. If you started with a config and ran "make oldconfig", you don't need the rest.

Categories

Upcoming Training