Welcome to the Linux Foundation Forum!

Debian 11 Bullseye dual monitor freezes after locking it and more...

kbourlesis
kbourlesis Posts: 1
edited January 20 in Debian

Hello everybody! This is my first post.

I just joined here as my last resort, after ~2 weeks of search, before I move to another distro. I am new to linux, not entirely though, and run away it's not my type. So, here is the problem(s):

After a fresh net install of Debian 11 (Bullseye) -there is no dual boot or anything- I stared the customization of my desktop, during the lock screen customization I noticed that when I lock up my session the screen freezes, however it may be available again in a random future time, alt+f2 (connect into tty session - no GUI just terminal) works and I am able to hear a youtube sound, if there is any playing at the time. I found out two things here:

1) That freeze goes away if I remove the second monitor.

2) My system doesn't have a xorg.conf file. So, if I auto configure the xorg (Xorg -configure) and place the xorg.conf into /etc/X1/xorg.conf.d/ directory then the lock screen freeze goes away as well, BUT! glitches appear.

I am not sure about where should I look, but I have looked at dmesg, .xsession-errors and journalctl.

.xsession-errors doesn't seem to contain something relevant to this case, I am not an expert though.

The only clues I have on screen freeze or glitches, are:

1) "[TTM] Buffer eviction failed"

2) "nouveau 0000:01:00.0: firmware: failed to load nouveau/nv84_xuc00f (-2)"

3) "nouveau 0000:01:00.0: Direct firmware load for nouveau/nv84_xu00f failed with error (-2)"

4) "nouveau 0000:01:00.0: vp: unable to load firmware nouveau/nv84_xu00f"

5) "nouveau 0000:01:00.0: vp: init failed, -2"

6) "nouveau 0000:01:00.0: bsp: unable to load firmware nouveau/nv84_xu103"

7) "nouveau 0000:01:00.0: bsp: init failed, -2"

At this point I should tell you that even with only one screen plugged, with or without xorg.conf inside the /etc/X1/xorg.conf.d/ directory, pc still freezes but not during lock screen. For example if I open like 5-6 youtube videos in firefox and then try to separate each one of them in different firefox instances (by dragging each tab out of the current instance). This time it could freeze entirely, ctrl+f2 doesn't work, no youtube sound and I need to hard reboot.

What I have tried so far:

1) install nvidia driver instead of nouveau. FAILED.

My nvidia graphics card is quiet old and the nvidia-legacy-340xx-driver is required. I know that Debian 11 doesn't support this driver but I found out that it is possible to be installed if I download it from Debian Sid's repository, which I did. I NEVER managed to install it properly or to make it run.

I also tried to run nvidia's script to install that driver and I messed my pc that much I had to format it. :D (Congratulations!!)

2) Manually configure the xorg.conf file (adding virtual memory etc.), which failed as well because I have no idea of xorg configuration, just other persons similar fixes.

Seems like a buffer filling up, overflowing or something for some reason.

The way I see it there are three possible causes:

1) xorg configuration

2) nouveau driver

3) KDE compositor

Categories

Upcoming Training