Welcome to the Linux Foundation Forum!

query to internal DNS view | Lab 6.4. Create a View

cdgmachado
cdgmachado Posts: 33
edited January 19 in LFS211 Class Forum

Hi guys,

On Lab 6.4. Create a View, one of the example queries to the internal DNS view is:

But the domain theworld.example.com is never defined in the zone file for that internal view:

So why does the answer to the query provided by the exercise is 192.74.137.5? Shouldn't it be NXDOMAIN like my answer from below?

Thanks in advanced!

P.S.: All my other queries were the same as that of the table. This one was the only exception.

Answers

  • lee42x
    lee42x Posts: 364

    I think the internal view has a default of recursive yes, and it should be recursive no like the external view. The IP address you highlighted is in fact the correct address for theworld.com.

  • I added recursion no; to the internal view, restarted bind9, but the answer is still the same (NXDOMAIN):

    And on /etc/bind/named.conf.options, recursion is also set to no:

    Also, on the guided exercise from the guide, for the internal view, recursion doesn't appear as one of the options to add on /etc/bind/named.conf.local:

    @lee42x

  • What makes me raise an eyebrow is that when recursion is set to no, the answer from dig says that recursion is being requested. But when I don't specify it, no comment regarding recursion appears on the reply (I've double checked this)

  • lee42x
    lee42x Posts: 364

    The recursion option is not consistent between CentOS and Ubuntu, this will get sorted next release. The ipaddress for theworld.example.com should be a failure. The ipaddress of192.74.137.5 belongs to theworld.com. The intent is to test the resolution on the different views.
    Lee

  • I tried dig theworld.com @127.0.0.1 but I get a status of REFUSED.

    Nonetheless, if the objective was to test the resolution on different views, then the job was done since I fully understood that. :)

    Thanks for the help again, Lee.

Categories

Upcoming Training