Welcome to the Linux Foundation Forum!

websocketConnectionTimeout, how to fix?



My Jenkins pipeline started failing with the error below:

java.io.IOException: Timed out waiting for websocket connection. You should increase the value of system property org.csanchez.jenkins.plugins.kubernetes.pipeline.ContainerExecDecorator.websocketConnectionTimeout currently set at 30 seconds

After some research it seems like it's a bug in the kubernetes pipeline plugin. At first I thought my cluster did go bad but after a reinstall I keep getting the same error. Does anyone know how I can set this system property? I tried in my Jenkinsfile like this:

stage('Compile') {
steps {
container('maven') {
sh 'mvn compile -Dorg.csanchez.jenkins.plugins.kubernetes.pipeline.ContainerExecDecorator.websocketConnectionTimeout=60'

But to no avail... please advise?


  • jsu
    jsu Posts: 5


    I just had the same issue and the cause is the Kubernetes plugin in Jenkins. Update it to the latest version and it will fix everything.

  • marvinleito

    thsnk you for the help! this fixed it! Sorry I pressed the wrong button and could not mark this as the answer!


Upcoming Training