Welcome to the Linux Foundation Forum!

Peer channel list - 'peer' not found

Hello All,

I am trying to run The Peer Command Section, my test-network is operational. I think I have downloaded everything but when I run the "peer channel list" command I get:

command 'peer' not found, did you mean:

command 'pee' from deb moreutils (0.63-1)
command 'pear' from deb php-pear (1:1.10.9+submodules+notgz-1ubuntu0.20.04.3)
command 'peet' from deb pipexec (2.5.5-2)
command 'peek' from deb peek (1.5.1-1)
command 'seer' from deb seer (1.1.4-2build2)
command 'beer' from deb gerstensaft (0.3-4.2)

First time posting on any forum (go easy on me :) )



  • Bobbijn
    Bobbijn Posts: 186

    Hello, Paul, Sorry to hear you are experiencing difficulties with this exercise. It looks like the issue is with the environment variables for ORG1. A suggestion would run the exercise( Lab 4.1) from the beginning making sure all the syntax are exact as in the exercise. Keep me updated as to your progress. Bobbi

  • Bobbi - thank you so much for getting back to me. Will try today and get back to you :)

  • export CORE_PEER_TLS_ROOTCERT_FILE=${PWD}/organizations/peerOrganizations/org1.example.com/peers/peer0.org1.example.com/tls/ca.crt

    I was running these as two separate commands :s

    A rookie mistake - but I am a rookie :D

  • Bobbijn
    Bobbijn Posts: 186

    Paul, Great to see it worked out. It is always about trial and error, keep on learning! Bobbi


Upcoming Training