Welcome to the Linux Foundation Forum!

issues with badge status

Hi, i am currently on video: Configuring Job Status with Commit Messages on chapter 6.

The issue i am having is that the image for the badge status is not appearing
how do i resolve this issue

Comments

  • jmarinho
    jmarinho Posts: 12

    Hi.

    I had the same problem that I solved when I notice that I did not connect the webhook with my Jenkins server. If, like in my scenario, you have your Jenkins server on a local virtual machine you must redirect the corresponding port of your home router to the corresponding port of the virtual machine.
    In my case, I'm using a Ubuntu 20.04 VM running on Virtualbox on bridge mode so it is on my local home network like the host machine and using my home router as gateway. You can redirect the 8080 port of your home router to the VM running the Jenkins server if your scenario is similar to mine.
    Once you are not doing Labs with the VM you can undo the redirection on your router.

    Hope that helps.

    Regards.

    PS: I see on your previous post that your Jenkins server runs on localhost so in this case is best to try the solution that luisvivero gave you. Only if you can't get it to work and only for the the time you need for the lab you can try to redirect the router 8080 port to your local machine.

  • Hi @davidboadu,

    This lab is a kind of long. Can you go through all the configuration again, and check if everything is in place? Perhaps the Worker Java App code has some errors (the changes in the README.md file).

    Is there any error in the Console Output? Did the tests on the pipeline work?

    It also can be what @jmarinho is mentioning.

    Regards,
    Luis.

  • @jmarinho

    thank you
    i followed your advice and it worked

  • jmarinho
    jmarinho Posts: 12

    I'm glad to hear that @davidboadu.

    Have a nice day.

Categories

Upcoming Training