Welcome to the Linux Foundation Forum!

Spinnaker installation

Hi there!

Great course, but concerning the last part with Spinnaker, I ran into an issue.

Indeed, when trying to install it with the script, I had a CrashLoopBackOff from the minio container. This issue was raised on github and I managed to fix it by directly editing the replicaset with a tagged image.

But even after doing so, connecting to the address gave me an error 404.

I don't know if it's related to the fact that I have way less containers running than Gourav on the video.

Any idea what's happening and/or how to fix it?

Thanks in advance for your help!

Comments

  • Hi @jsu ,

    I'm not aware of the issue. Can you provide the Chapter and Section, and the exact command and output you are running/getting, please?

    Regards,
    Luis.

  • jsu
    jsu Posts: 5

    Hi @luisviveropena,

    It is on Chapter 13: Continuous Deployment with Spinnaker, Section Setting Up Spinnaker on GCP.

    The minnaker installation with the script doesn't work. I used the command that was provided in the course (and on https://github.com/armory/minnaker)

    ./scripts/install.sh -o -P $EXTERNAL_IP
    

    and I had a CrashLoopBackOff with minio. I don't have the exact logs right now as actually I forgot to send this message last Thursday and I moved on to the next course.

  • Hi @jsu, I was able to reproduce the issue. We are investigating about this, and will provide you an update as soon as we have news.

    Regards,
    Luis.

  • I have the same issue. @jsu please let me know if you found the solution.

  • zinebhalib
    zinebhalib Posts: 2
    edited November 2021

    I found the solution here https://github.com/armory/minnaker/issues/102
    "What worked for me was editing spinsvc/infrastructure/minio.yml, changing the path from /usr/bin/minio to /opt/bin/minio and then running ./deploy.sh, then deleting the old minio-0 pod."

  • Hi @zinebhalib , I opened that bug few days ago, hehehe. I haven't tried the workaround, I'll try it asap.

    Thanks for the update!

    Luis.

Categories

Upcoming Training