Welcome to the Linux Foundation Forum!

Lab 10.2. Use rsync Over ssh to Add the *.bin Files Only to Previously Created Folder


Hi fellow learners,

I am currently trying to do this lab but i have got this error whenever i try to use the root localhost

I keep getting permission denied.

please can i have some help with this one how do i deal with this so i can achieve the desired result


  • lee42x
    lee42x Posts: 380

    Thank you for your comments,

    In exercise 5.3 we configure ssh keys for student to be able to allow user student to ssh to localhost as root without a password. If the keys were not deployed then ssh would prompt for a password but not use it.

    Exercise 10.2 copies files as user student to the localhost system as root.

    Your command shows root (sudo) sending files to localhost as root, if root has the correct entry in /root/.ssh/authorized_keys it will work however we do not set up the keys for root in lab 5 or lab 10.
    Debugging information is available with the "-v" option of scp.

    To test this theory remove the line (comment it out) "PermitRootLogin without-password" and restart the sshd service, and test. Once this works, correct the authorized_keys file as indicated in chapter 5.

    Keep us posted, Lee

  • davidboadu

    hi thank for your advice. I remember that in the past in chapter 5, i tried to do the exercise but i kept getting bad configuration error so i gave up on it.

    Also when i tried to copy the authorised keys over to root. i get a bash permission denied error
    is this suppose to happen

    I decided to implement your advice by using -v option

    and here is what i got

    I do not understand why it says denied after waiting for reply
    the send packet is type 50 and the receive packet is type 51.

    Is this the reason why i am getting an error?


Upcoming Training