Welcome to the Linux Foundation Forum!

I am unable to download the course material mentioned in Chapter 2 Lab 2.1

esmapen Posts: 2
edited September 2021 in LFD259 Class Forum

The download link provided as follows:

To assist with setting up your cluster please download the tarball of shell scripts and YAML files. Thek8scp.shandk8sSecond.shscripts deploy a Kubernetes cluster usingkubeadmand useProject Calicofor networking. Shouldthe file not be found you can always use a browser to investigate the parent directory.

$ wget https://training.linuxfoundation.org/cm/LFD259/LFD259V2021-07-29SOLUTIONS.tar.xz--user=xxxxxx --password=xxxxx

$ tar -xvf LFD259V2021-07-29SOLUTIONS.tar.xz

(Note: depending on your software, if you are cutting and pasting the above instructions, the underscores may disap-pear and be replaced by spaces, so you may have to edit the command line by hand!)V2021-07-29© Copyright the Linux Foundation 2021. All rights reserved.

I tried to download the content using browser but i am getting "Page Not Found" error and throw command prompt i am getting following error

401 authentication error. I tried both with the username/pwd shared in the command and with my linux foundation credentials but output is same.

Please suggest the way forward :(


  • fcioanca
    fcioanca Posts: 1,966
    edited September 2021

    Hi @esmapen,

    Please pay attention to the note that is under the given command, which mentions the fact that in some instances, the underscores may disappear. In your post, these underscores have indeed disappeared, hence the error you got. Please pay attention to ensure that you are using the correct and complete command. Also, it seems that a space is missing between '....tar.xz' and '--user...'

    The Linux Foundation Training Team

  • esmapen

    Thanks! It's working now.


Upcoming Training