Welcome to the Linux Foundation Forum!

Chapter 9.2 Lab exer

reuben158
reuben158 Posts: 6
edited August 19 in LFW212 Class Forum

I was able to do npm install on the lab folder and updated the application according to the specifications of the problem however when I run node validate, the app cant start and the script gives a random PORT number. how exactly should I run validate.js?

Comments

  • hey @reuben158 I'll need to see your code to be able to help you with this, if you can post your solution here I'll take a look

  • reuben158
    reuben158 Posts: 6
    edited September 6

    hi @davidmarkclements, I am encountering the same issue with lab 10.2. I just ran npm install on what is given since there is already a base code given in the folder and when I tried to run validate.js, I just get the server did not run in time. nothing works even with the base code. I think I encountered this with the last 3 exercises. can you give any tips on how to make this work. I can seem to test my solution because initially the test scripts are giving me errors that the server did not start on time.

  • kinda weird. I already fixed my issues on the server did not start on time error by using WSL instead of running the code in Windows.

  • @reuben158 okay, seems like a windows bug, we're you in cmd.exe or powershell? Glad you found a way forward

Categories

Upcoming Training