Welcome to the Linux Foundation Forum!

Labels and annotations not working using manifest file | but the same is working using CLI commands


Somehow when i Add labels and annotations in manifest file its not working

I tried to add labels and annotations in the metadata block in manifest, deleted the old app and then re-pushed using the manifest file which had below block added:

contact: "bob@example.com"
env: dev

cf labels app training-app doesn't shows anything.

If the same I try using set-label commend then its working.
Anybody else facing similar issue?


  • spgreenberg

    What Cloud Foundry instance/provider are you using? Also, what version of the CLI are you using?

  • mohitagarwal2211

    I am using anynine cloud foundry instance.
    Verison is : cf version 7.2.0+be4a5ce2b.2020-12-10

  • spgreenberg
    spgreenberg Posts: 86
    edited October 2021

    Hi @mohitagarwal2211. I was able to test this using the same CLI and Anynines. Could you check for the indentation in the manifest? If it isn't correct, it will not error (as manifests are extensible) but the labels won't be set. The manifest I used (a different app) is below).

    - name: first-push
      instances: 1
      memory: 32M
      disk_quota: 64M
      path: ./sample-app.zip
      - route: ((route))
      - go_buildpack
          contact: "bob@example.com"
          env: dev
  • mohitagarwal2211
    mohitagarwal2211 Posts: 4
    edited October 2021

    Hi @spgreenberg , my bad indentation was incorrect due to which it was not showing, after correction it worked fine.
    Just a suggestion it should prompt an error in manifest file during compilation itself for such mistakes.

    Also the sample provided training-app is giving error and no longer getting compiled. Can you get this checked and corrected please as newbie learner its difficult to learn without doing actual labs:

    mohit@ubuntu:~/Downloads/cbc0k2m6h2pe-applications/applications/training-app$ cf push -f manifest.yml -p training-app.zip --random-route
    Pushing app training-app to org mohit_agarwal2211_gmail_com / space staging as mohit.agarwal2211@gmail.com...
    Applying manifest file manifest.yml...
    Manifest applied
    Packaging files to upload...
    Uploading files...
     14.28 KiB / 14.28 KiB [=======================================================================================================================================================================] 100.00% 1s
    Waiting for API to complete processing files...
    Staging app and tracing logs...
       Downloading go_buildpack...
       Downloaded go_buildpack
       Cell fa13b665-1823-4138-8648-ee159d54d29e creating container for instance 586dc8c7-2f45-4359-94b5-c386ce900c00
       Cell fa13b665-1823-4138-8648-ee159d54d29e successfully created container for instance 586dc8c7-2f45-4359-94b5-c386ce900c00
       Downloading app package...
       Downloaded app package (74.5K)
       -----> Go Buildpack version 1.9.35
              **WARNING** Please use AppDynamics extension buildpack for Golang Application instrumentation
              **WARNING** for more details: https://docs.pivotal.io/partners/appdynamics/multibuildpack.html
       -----> Installing godep 80
              Download [https://buildpacks.cloudfoundry.org/dependencies/godep/godep-v80-linux-x64-cflinuxfs3-b60ac947.tgz]
       -----> Installing glide 0.13.3
              Download [https://buildpacks.cloudfoundry.org/dependencies/glide/glide-v0.13.3-linux-x64-cflinuxfs3-ef07acb5.tgz]
       -----> Installing dep 0.5.4
              Download [https://buildpacks.cloudfoundry.org/dependencies/dep/dep-v0.5.4-linux-x64-cflinuxfs3-79b3ab9e.tgz]
       -----> Installing go 1.16.7
              Download [https://buildpacks.cloudfoundry.org/dependencies/go/go_1.16.7_linux_x64_cflinuxfs3_8a3a18cd.tgz]
              **ERROR** problem retrieving main package name: go: github.com/cloudfoundry-community/go-cfenv@v1.18.0: missing go.sum entry; to add it:
                go mod download github.com/cloudfoundry-community/go-cfenv
              **ERROR** Unable to determine import path: exit status 1
    BuildpackCompileFailed - App staging failed in the buildpack compile phase
  • tsouvalasi
    tsouvalasi Posts: 5
    edited October 2021

    Heya there @mohitagarwal2211,

    I had stumbled on that issue myself on Friday. Given I don't take no for an answer or better described failure for an outcome, I tried a number of options which although it admittedly took far more time than intended, I ended up with a working version of the training-application:

    As discussed on this thread, issuing go mod tidy did the trick. Specifically:

    1. unzip training-app.zip
    2. cd training-app
    3. go mod tidy
    4. copy manifest.yml to the root of the application
    5. cf push training-app -f manifest.yml --random-route

    On the steps above I've obviously skipped the -p path option to the compressed folder. Let me know if that works for you as expected.


  • mohitagarwal2211

    @tsouvalasi It worked perfectly , Thank you !!


Upcoming Training