Welcome to the Linux Foundation Forum!

Lab 2.1: Fail to 'Spin up the network'

collin.chu
collin.chu Posts: 5
edited July 27 in LFD272 Class Forum

After setup the environment, tried to spin up the test network, when ran './network.sh up createChannel -ca -s couchdb', got the following error:

  • peer channel create -o localhost:7050 -c mychannel --ordererTLSHostnameOverride orderer.example.com -f ./channel-artifacts/mychannel.tx --outputBlock ./channel-artifacts/mychannel.block --tls --cafile /home/ubuntu/go/src/github.com/hyperledger/fabric-samples/test-network/organizations/ordererOrganizations/example.com/orderers/orderer.example.com/msp/tlscacerts/tlsca.example.com-cert.pem
  • res=1
    Error: failed to create deliver client for orderer: orderer client failed to connect to localhost:7050: failed to create new connection: connection error: desc = "transport: error while dialing: dial tcp 127.0.0.1:7050: connect: connection refused"
    Channel creation failed

Anyone could give me clue?

Thanks!

Comments

  • Hi Collin. I think I had a similar issue as you. What docker-compose version are you using? I was using version 2 but i downgraded to docker-compose v1 and then this worked for me as expected.

  • My version is latest one. Not sure if your solution is good for me. The weird thing is, after initial installation, everything worked well. The issue happened after I ran a few applications and clean network artifacts.

  • hishmad
    hishmad Posts: 2

    Hi every body, I just started this course, and experiencing the same error "Channel creation failed" any clue?

  • Bobbijn
    Bobbijn Posts: 75

    @hishmad, Hello, Let's see if we can figure this out. This error usually occurs when one of the dependencies is out of sync. Please go back and check the versions of the dependencies, especially Docker. Let me know if this helps. Bobbi

  • hishmad
    hishmad Posts: 2

    Hi @Bobbijn ,
    Thank you,

    In my case, I'm using remote VPS in the cloud running Ubuntu 20.04, and there was an issue with the user's permission. my solution was after resolving the main cause by granting privilege to the user, it was necessary to call "./network.sh down" before going to start the test network.

  • Bobbijn
    Bobbijn Posts: 75

    :)

Categories

Upcoming Training