Welcome to the Linux Foundation Forum!

For some Reason Internet is not working for me on VM Where as it's Working on Windows Host

I was going through Lab 4.1 it prompted to download fabric peer image with below error :

Error Message : Error: chaincode install failed with status: 500 - failed to invoke backing implementation of 'InstallChaincode': could not build chaincode: docker build failed: docker image build failed: docker build failed: Failed to pull hyperledger/fabric-nodeenv:2.2: API error (500): Get https://registry-1.docker.io/v2/: dial tcp: lookup registry-1.docker.io: Temporary failure in name resolution

Later I figured out Internet has stopped working on VM. Mozilla browser is continuously throwing Server Not Found Error. PFA Network settings snapshot. I have tried few solutions available over Internet but nothing has worked for me. Did anyone face similar issue ?
Thanks,

Comments

  • Bobbijn
    Bobbijn Posts: 75

    @singhraj , Hello let's see if we can get to the bottom of this. Its sound as if your internet connection is unstable which can be the cause of the issue. Have you attempted the exercise again and if so what were the results? Bobbi

  • singhraj
    singhraj Posts: 3

    Thanks for responding @Bobbijn . Even i felt the same that why I recreated new VM using the image shared in the prerequisites section. Now i am able to download all docker images and access internet from the VM itself.

  • Bobbijn
    Bobbijn Posts: 75

    Great Job , Keep learning!

Categories

Upcoming Training