Welcome to the Linux Foundation Forum!

Upgraded 2.2 Course using node js as default Chaincode lang instead of go lang

Hi There,
Before up-gradation of course from Fabric 1.4 to 2.2, all smart contracts in course content were in go language. Now after upgrading, it is seen to be in nodejs. Any specific reason to tread node js as default language?

Regards,
Sumit

Comments

  • fcioanca
    fcioanca Posts: 1,007

    The CHFD exam made this change, to use Node.js for smart contracts. The course was also aligned with the exam while we upgraded it to Fabric 2.2.

  • singhraj
    singhraj Posts: 3

    Hello ,

    So are we going to have only Node.js for smart contracts in Fabric version 2.2? Are there any plans to include Golang examples as well in the learning material ?

    Thanks

  • fcioanca
    fcioanca Posts: 1,007

    Hi @singhraj

    At this time there are no plans to include Golang examples in the course.

    Regards,

    Flavia

    The Linux Foundation Training Team

  • Bobbijn
    Bobbijn Posts: 78

    Here is a resources you might find Helpful:
    https://hyperledger-fabric.readthedocs.io/en/latest/whatsnew.html

  • pbmystman
    pbmystman Posts: 1

    Hi!

    Is there any chance to access the previous version of the course with examples in Go?
    I appreciate the update, but I was really looking forward to do the exercises in Go. :-/

    Thanks,
    Peter

  • fcioanca
    fcioanca Posts: 1,007

    Hi Peter, no, it's not possible to access previous course versions.
    Regards,
    Flavia

Categories

Upcoming Training