Welcome to the Linux Foundation Forum!

Confusion regarding Fabric Version

Hi,
I'm using this to prepare for CHFD exam. I'm confused about which version of Fabric should I use.
In the Lab 2.1. Development Environment Setup, It's mentioned that all resources should be used as per Fabric 1.4.7.
But in https://docs.linuxfoundation.org/tc-docs/certification/tips-chfd#resources-allowed-during-the-chfd-exam,
Fabric 2.2 is mentioned.

Can anyone help me out with this.

Comments

  • fcioanca
    fcioanca Posts: 989

    @Rajatsharma The course is still on Fabric 1.4.7. We are currently finalizing the updates to bring it to Fabric 2.2. We will post in the forum when these updates are live.

  • Rajatsharma
    Rajatsharma Posts: 5

    Just to confirm, the CHFD test is on Fabric 2.2 or even that's on Fabric 1.4.7?

  • fcioanca
    fcioanca Posts: 989

    @Rajatsharma The CHFD exam is on Fabric 2.2, as indicated in the exam documentation. Only the course is still on 1.4.7, for now.

  • Rajatsharma
    Rajatsharma Posts: 5

    Do we have an ETA for the update?

    I'm preparing for CHFD and I'm stuck with this, should I try to practice writing chaincodes with shim or contractAPI.
    And a lot of questions like this.

  • fcioanca
    fcioanca Posts: 989

    We hope to roll out the updates in the coming weeks.

  • Rajatsharma
    Rajatsharma Posts: 5

    Okay. Then I'll wait for the update before continuing with the preparation.
    Hope we get the update soon!!!

  • fcioanca
    fcioanca Posts: 989

    We will post in the forum when the updates are live.

  • Rajatsharma
    Rajatsharma Posts: 5

    @fcioanca, do we have any updates?

  • fcioanca
    fcioanca Posts: 989

    @Rajatsharma The updated version should be live by the end of next week. We will post in the forum when that happens.

Categories

Upcoming Training