Welcome to the Linux Foundation Forum!

Study v2.2 while exam on v1.4

Hi, just took the exam yesterday. It is on v1.4. I mainly practised on v2.2, therefore I am not familiar with v1.4 and do not expect good result in the exam. Today I tried to pick up and practise v1.4 tutorial from the official Hyperledger Fabric website. I found some materials are outdated so I couldn't run it smoothly.

For example, when I tried to pull fabric-sample release-1.4, it would miss the content from directories bin, config and chaincode. Even I add them back manually and do ./bysh up again, peers would complain it doesn't have the chaincode.

2021-03-07 11:34:50.384 UTC [chaincodeCmd] checkChaincodeCmdParams -> INFO 001 Using default escc
2021-03-07 11:34:50.384 UTC [chaincodeCmd] checkChaincodeCmdParams -> INFO 002 Using default vscc
Error: error getting chaincode code mycc: path to chaincode does not exist: /opt/gopath/src/github.com/chaincode/chaincode_example02/go
!!!!!!!!!!!!!!! Chaincode installation on peer0.org1 has failed !!!!!!!!!!!!!!!!

Another example is for fabcar. It would complain about node / node-gyp version which I stuck for half day to fix.

This really makes me appreciate the work done for v2.2. Now struggle if I should keep on tutorial v1.4 for re-taking the exam, or move on to v2.2. Any advice?

Comments

Sign In or Register to comment.