Welcome to the Linux Foundation Forum!

Lab 7 – Using Multiple Fluentd Instances, Configuring High Availability and Testing Failover in Flue


On Page 7
docker run -p 25500:25500 --name aggregator2 -v $HOME/lab7/aggregator2:/fluentd/etc -e FLUENTD_CONF=aggregator2.conf fluent/fluentd:stable

/usr/lib/ruby/gems/2.5.0/gems/fluentd-1.3.2/lib/fluent/supervisor.rb:760:in `initialize': No such file or directory @ rb_sysopen - /fluentd/etc/aggregator2.conf (Errno::ENOENT

I've tried changing to /home/user and still the same issue. What am I doing wrong here?


  • Hi nfstern,

    I tried your command and there is nothing wrong with it. Can you like the output of ls -l $HOME/lab7/aggregator2?

    You can also try specifying a wildcard for the FLUENTD_CONF variable as shown in the text: docker run -p 25500:25500 --name aggregator2 -v $HOME/lab7/aggregator2:/fluentd/etc \ -e FLUENTD_CONF=aggregator*.conf fluent/fluentd:stable

  • nfstern
    nfstern Posts: 4
    edited February 2021

    My bad and humble apologies. I misspelled aggregator.conf as aggegator.conf. Missing an 'r' in the name. Please close this as resolved.

    There's nothing wrong with the command and once I fixed the name of the file it worked fine.

  • Sometimes all you need is a second set of eyes, glad you managed to resolve it. Thank you for reaching out.

This discussion has been closed.


Upcoming Training