Welcome to the Linux Foundation Forum!

Cross compiling PAM for powerpc: missing /etc/pam.d and pam.conf

I am trying to cross-compile Linux-PAM from a Ubuntu host machine to powerpc architecture (running linux kernel 2.6.34). First, I run ./configure command, giving the --host path to the cross compiler and --prefix path to a local directory called "target" as options to the configure command; after that, I run make and make install. The make install command ends apparently without any error. At the end of the install process few files and directories are created in my "target" folder, but the /etc/pam.d is missing: I would have expected to find that folder, containing the PAM modules. A pam.conf file is missing too. Am I doing something wrong? Or maybe the lack of both /etc/pam.d and pam.conf is an expected behavior? these are the commands I tried to cross-compile:

export PATH=/path/to/crosscompiler/$PATH
./configure --prefix=/home/target --host=powerpc-unknown-linux-gnu
make
make install

Thanks a lot.

Sign In or Register to comment.