Welcome to the Linux Foundation Forum!

Unable to install Docker image on Minion node



I am working on 'Lab 3.2. Configure a Local Docker Repository'.

I need help with deploying docker images on the minion node of my k8s cluster. The master node seems to be running fine, but the minion node keeps throwing exceptions that I am unable to resolve.

This is the error I get when I run 'kubeadm init':
invalid or incomplete external CA: failure loading certificate for API server: failed to load certificate: couldn't load the certificate file /etc/kubernetes/pki/apiserver.crt: open /etc/kubernetes/pki/apiserver.crt: no such file or directory

When I run command 'kubectl version':
The connection to the server localhost:8080 was refused - did you specify the right host or port?

How might I be able to resolve this problem?



  • aparajithanv

    Adding a screenshot:

  • chrispokorni

    Hi @aparajithanv,

    It seems you are seeing errors because the steps in the lab are not followed as presented.

    There are inconsistencies between your docker commands - the ones with sudo seem to work, while the ones without sudo produce permission errors. When comparing them with lab exercise steps, do you see what is missing from some of your commands?

    As far as running kubectl, are you attempting that command on your minion node? Did you find such a step in the exercise? Based on the bootstrapping steps of our cluster from the previous chapter, the kubectl CLI client is only setup to work from the control/primary node.


  • aparajithanv



Upcoming Training